National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-0888 Detail

Current Description

Heap-based buffer overflow in the JBIG2 filter in Adobe Reader 7 and Acrobat 7 before 7.1.3, Adobe Reader 8 and Acrobat 8 before 8.1.6, and Adobe Reader 9 and Acrobat 9 before 9.1.2 might allow remote attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2009-0510, CVE-2009-0511, CVE-2009-0512, and CVE-2009-0889.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Victim must voluntarily interact with attack mechanism
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://security.gentoo.org/glsa/glsa-200907-06.xml
http://securitytracker.com/id?1022361
http://www.adobe.com/support/security/bulletins/apsb09-07.html Patch Vendor Advisory
http://www.redhat.com/support/errata/RHSA-2009-1109.html
http://www.securityfocus.com/bid/35274
http://www.us-cert.gov/cas/techalerts/TA09-161A.html US Government Resource
http://www.vupen.com/english/advisories/2009/1547 Patch Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/a:adobe:acrobat:7.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.1::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.2
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.2::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.2::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.3
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.3::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.3::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.4
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.4::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.4::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.5
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.5::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.5::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.6
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.6::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.6::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.7
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.7::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.7::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.8
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.8::elements
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.8::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.8::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.9
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.0.9::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:7.1.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.0::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.0::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.1::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.2
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.2::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.2::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.2:security_update:professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.3
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.3::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.3::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.4
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.4::professional
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:8.1.4::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9.0::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9.0.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat:9.1::standard
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.2
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.3
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.4
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.5
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.6
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.7
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.8
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.0.9
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:7.1.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.0
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.2
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.2:security_update
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.3
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.4
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:8.1.5
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:9
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:9.1
     Show Matching CPE(s)
 cpe:/a:adobe:acrobat_reader:9.1.1
     Show Matching CPE(s)


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-0888
NVD Published Date:
06/11/2009
NVD Last Modified:
08/12/2009