CVE-2009-1392 Detail

Current Description

The browser engine in Mozilla Firefox 3 before 3.0.11, Thunderbird before 2.0.0.22, and SeaMonkey before 1.1.17 allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to (1) nsEventStateManager::GetContentState and nsNativeTheme::CheckBooleanAttr; (2) UnhookTextRunFromFrames and ClearAllTextRunReferences; (3) nsTextFrame::ClearTextRun; (4) IsPercentageAware; (5) PL_DHashTableFinish; (6) nsListBoxBodyFrame::GetNextItemBox; (7) AtomTableClearEntry, related to the atom table, DOM mutation events, and Unicode surrogates; (8) nsHTMLEditor::HideResizers; and (9) nsWindow::SetCursor, related to changing the cursor; and other vectors.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://rhn.redhat.com/errata/RHSA-2009-1096.html Patch  Vendor Advisory 
http://securitytracker.com/id?1022376 Patch 
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.372468
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.425408
http://sunsolve.sun.com/search/document.do?assetkey=1-26-265068-1
http://sunsolve.sun.com/search/document.do?assetkey=1-77-1020800.1-1
http://www.debian.org/security/2009/dsa-1820
http://www.debian.org/security/2009/dsa-1830
http://www.mandriva.com/security/advisories?name=MDVSA-2009:141
http://www.mozilla.org/security/announce/2009/mfsa2009-24.html Vendor Advisory 
http://www.redhat.com/support/errata/RHSA-2009-1125.html
http://www.redhat.com/support/errata/RHSA-2009-1126.html
http://www.securityfocus.com/bid/35326
http://www.securityfocus.com/bid/35370
http://www.securitytracker.com/id?1022397
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.454275
http://www.ubuntu.com/usn/usn-782-1
http://www.vupen.com/english/advisories/2009/1572 Patch  Vendor Advisory 
http://www.vupen.com/english/advisories/2009/2152
https://bugzilla.mozilla.org/show_bug.cgi?id=380359 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=429969 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=431086 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=432068 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=451341 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=472776 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=486398 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=489041 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=490410 Exploit 
https://bugzilla.mozilla.org/show_bug.cgi?id=490425
https://bugzilla.mozilla.org/show_bug.cgi?id=490513 Exploit 
https://bugzilla.redhat.com/show_bug.cgi?id=503568 Exploit 
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9501
https://rhn.redhat.com/errata/RHSA-2009-1095.html Patch  Vendor Advisory 
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg00574.html
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg00657.html

Weakness Enumeration

CWE-ID CWE Name Source
CWE-94 Improper Control of Generation of Code ('Code Injection') cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-1392
NVD Published Date:
06/12/2009
NVD Last Modified:
10/30/2018
Source:
MITRE