National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-1869 Detail

Description

Integer overflow in the ActionScript Virtual Machine 2 (AVM2) abcFile parser in Adobe Flash Player before 9.0.246.0 and 10.x before 10.0.32.18, and Adobe AIR before 1.5.2, allows attackers to cause a denial of service (application crash) or possibly execute arbitrary code via an AVM2 file with a large intrf_count value that triggers a dereference of an out-of-bounds pointer.

Source:  MITRE
Description Last Modified:  07/31/2009

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Victim must voluntarily interact with attack mechanism
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.apple.com/archives/security-announce/2009/Sep/msg00003.html
http://lists.apple.com/archives/security-announce/2009/Sep/msg00004.html
http://roeehay.blogspot.com/2009/08/advisory-adobe-flash-player-avm2.html
http://roeehay.blogspot.com/2009/08/exploitation-of-cve-2009-1869.html
http://security.gentoo.org/glsa/glsa-200908-04.xml
http://sunsolve.sun.com/search/document.do?assetkey=1-66-266108-1
http://support.apple.com/kb/HT3864
http://support.apple.com/kb/HT3865
http://www.adobe.com/support/security/bulletins/apsb09-10.html Patch Vendor Advisory
http://www.adobe.com/support/security/bulletins/apsb09-13.html
http://www.securityfocus.com/archive/1/archive/1/505467/100/0/threaded
http://www.securityfocus.com/bid/35890 Patch
http://www.securityfocus.com/bid/35907
http://www.securitytracker.com/id?1022629
http://www.vupen.com/english/advisories/2009/2086 Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/52181
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A15994
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6998

References to Check Content

Identifier:
oval:org.mitre.oval:def:6998
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:6998

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/a:adobe:air:1.0
cpe:/a:adobe:air:1.1
cpe:/a:adobe:air:1.01
cpe:/a:adobe:air:1.5
cpe:/a:adobe:air    versions up to (including) 1.5.1
cpe:/a:adobe:flash_player:7.0
cpe:/a:adobe:flash_player:7.0.1
cpe:/a:adobe:flash_player:7.0.25
cpe:/a:adobe:flash_player:7.0.63
cpe:/a:adobe:flash_player:7.0.63::linux
cpe:/a:adobe:flash_player:7.0.69.0
cpe:/a:adobe:flash_player:7.0.70.0
cpe:/a:adobe:flash_player:7.1
cpe:/a:adobe:flash_player:7.1.1
cpe:/a:adobe:flash_player:7.2
cpe:/a:adobe:flash_player:8.0
cpe:/a:adobe:flash_player:8.0::basic
cpe:/a:adobe:flash_player:8.0::pro
cpe:/a:adobe:flash_player:8.0.24.0
cpe:/a:adobe:flash_player:8.0.34.0
cpe:/a:adobe:flash_player:8.0.35.0
cpe:/a:adobe:flash_player:8.0.39.0
cpe:/a:adobe:flash_player:9.0.16
cpe:/a:adobe:flash_player:9.0.20
cpe:/a:adobe:flash_player:9.0.20.0
cpe:/a:adobe:flash_player:9.0.28
cpe:/a:adobe:flash_player:9.0.28.0
cpe:/a:adobe:flash_player:9.0.31.0
cpe:/a:adobe:flash_player:9.0.45.0
cpe:/a:adobe:flash_player:9.0.47.0
cpe:/a:adobe:flash_player:9.0.48.0
cpe:/a:adobe:flash_player:9.0.112.0
cpe:/a:adobe:flash_player:9.0.114.0
cpe:/a:adobe:flash_player:9.0.115.0
cpe:/a:adobe:flash_player:9.0.124.0
cpe:/a:adobe:flash_player:10.0.0.584
cpe:/a:adobe:flash_player:10.0.12.10
cpe:/a:adobe:flash_player:10.0.12.36
cpe:/a:adobe:flash_player    versions up to (including) 10.0.22.87
cpe:/a:adobe:flex:3.0

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-1869
NVD Published Date:
07/31/2009
NVD Last Modified:
09/28/2017