National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-4270 Detail

Description

Stack-based buffer overflow in the errprintf function in base/gsmisc.c in ghostscript 8.64 through 8.70 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PDF file, as originally reported for debug logging code in gdevcups.c in the CUPS output driver.

Source:  MITRE      Last Modified:  12/21/2009

Quick Info

CVE Dictionary Entry:
CVE-2009-4270
Original release date:
12/21/2009
Last revised:
01/09/2015
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
9.3 HIGH
Vector:
(AV:N/AC:M/Au:N/C:C/I:C/A:C) (legend)
Impact Subscore:
10.0
Exploitability Subscore:
8.6
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Medium
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (12/22/2009)

Not vulnerable. This issue did not affect the versions of ghostscript as shipped with Red Hat Enterprise Linux 3, 4, or 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://bugs.ghostscript.com/show_bug.cgi?id=690829 External Source CONFIRM http://bugs.ghostscript.com/show_bug.cgi?id=690829
http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html External Source SUSE SUSE-SR:2010:014
http://security.gentoo.org/glsa/glsa-201412-17.xml External Source GENTOO GLSA-201412-17
http://www.mandriva.com/security/advisories?name=MDVSA-2010:134 External Source MANDRIVA MDVSA-2010:134
http://www.mandriva.com/security/advisories?name=MDVSA-2010:135 External Source MANDRIVA MDVSA-2010:135
http://www.openwall.com/lists/oss-security/2009/12/18/1 External Source MLIST [oss-security] 20091217 possible vulnerability in ghostscript >= 8.64
http://www.openwall.com/lists/oss-security/2009/12/18/2 External Source MLIST [oss-security] 20091218 Re: possible vulnerability in ghostscript >= 8.64
http://www.securityfocus.com/bid/37410 Exploit External Source BID 37410
http://www.ubuntu.com/usn/USN-961-1 External Source UBUNTU USN-961-1
http://www.vupen.com/english/advisories/2009/3597 Vendor Advisory External Source VUPEN ADV-2009-3597
https://bugzilla.redhat.com/show_bug.cgi?id=540760 External Source CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=540760

Technical Details

Vulnerability Type (View All)

Change History 2 change records found - show changes