National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2010-0832 Detail

Current Description

pam_motd (aka the MOTD module) in libpam-modules before 1.1.0-2ubuntu1.1 in PAM on Ubuntu 9.10 and libpam-modules before 1.1.1-2ubuntu5 in PAM on Ubuntu 10.04 LTS allows local users to change the ownership of arbitrary files via a symlink attack on .cache in a user's home directory, related to "user file stamps" and the motd.legal-notice file.

Source:  MITRE
Description Last Modified:  07/12/2010
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.9 MEDIUM
Vector: (AV:L/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.4


Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Victim must voluntarily interact with attack mechanism
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://twitter.com/jonoberheide/statuses/18009527979
http://www.exploit-db.com/exploits/14273 Exploit
http://www.h-online.com/security/news/item/Ubuntu-closes-root-hole-1034618.html
http://www.securityfocus.com/bid/41465 Exploit Patch
http://www.ubuntu.com/usn/USN-959-1 Vendor Advisory
http://www.vupen.com/english/advisories/2010/1747 Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/60194

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/o:canonical:ubuntu_linux:10.04:-:lts
Configuration 2
OR
cpe:/o:canonical:ubuntu_linux:9.10

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-0832
NVD Published Date:
07/12/2010
NVD Last Modified:
08/16/2017