National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2010-1104 Detail

Description

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Source:  MITRE
Description Last Modified:  03/25/2010

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

Vendor Statements (disclaimer)

Official Statement from Red Hat (04/21/2010)

Red Hat is aware of this issue and is tracking it via the following bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=CVE-2010-1104 The Red Hat Security Response Team has rated this issue as having moderate security impact, a future update may address this flaw.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/37765
http://www.vupen.com/english/advisories/2010/0104 Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/55599
https://mail.zope.org/pipermail/zope-announce/2010-January/002229.html Patch Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:zope:zope:2.8:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0-a1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0-a2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0-b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0-b2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.0-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.1-b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.1-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.3:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.4:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.5:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.6:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.7:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.8:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.9:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.9.1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.10:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.8.11:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.0:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.0-b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.0-b2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.3:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.4:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.5:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.6:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.7:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.8:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.9:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.10:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.9.11:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.0-b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.0-b2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.0-c1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.0-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.2-b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.2-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.3:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.3-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.4-final:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.5:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.6:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.7:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.8:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.9:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.10:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.10.11:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.0:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.0a1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.0b1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.0c1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.2:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.3:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.4:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.11.5:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.12.0:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.12.1:*:*:*:*:*:*:*
cpe:2.3:a:zope:zope:2.12.2:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-1104
NVD Published Date:
03/25/2010
NVD Last Modified:
08/16/2017