U.S. flag   An official website of the United States government
Dot gov

Official websites use .gov
A .gov website belongs to an official government organization in the United States.

Https

Secure .gov websites use HTTPS
A lock (Dot gov) or https:// means you've safely connected to the .gov website. Share sensitive information only on official, secure websites.

CVE-2010-3070 Detail

Current Description

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=595248
http://git.debian.org/?p=users/olberger-guest/nusoap.git;a=blob;f=debian/patches/595248.patch;h=6af3d725fe74d839764d9755c5bb18458a192518;hb=268f03b88c6900d1a87b17734c248c705c22cb07
http://git.debian.org/?p=users/olberger-guest/nusoap.git;a=blobdiff;f=debian/patches/595248.patch;h=11202fa70433b62aeab7dfc68af668329bc0fe7e;hp=6af3d725fe74d839764d9755c5bb18458a192518;hb=3ac7a26a49086c6b91fb79e5acafcfcdc5d6980a;hpb=268f03b88c6900d1a87b17734c248c705c22cb07
http://git.mantisbt.org/?p=mantisbt.git;a=commit;h=edb817991b99cd5538f102be26865fde7c6b7212
http://lists.fedoraproject.org/pipermail/package-announce/2010-September/048317.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-September/048325.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-September/048548.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-September/048639.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-September/048659.html
http://sourceforge.net/mailarchive/message.php?msg_name=4C8FC573.3060900%40leetcode.net
http://sourceforge.net/projects/nusoap/forums/forum/193579/topic/3834005
http://www.mantisbt.org/bugs/changelog_page.php?version_id=111
http://www.mantisbt.org/bugs/view.php?id=12312
http://www.openwall.com/lists/oss-security/2010/09/03/2
http://www.openwall.com/lists/oss-security/2010/09/07/4
http://www.openwall.com/lists/oss-security/2010/09/14/12
http://www.openwall.com/lists/oss-security/2010/09/14/13
http://www.securityfocus.com/bid/42959
http://www.vupen.com/english/advisories/2010/2535
https://bugzilla.redhat.com/show_bug.cgi?id=629585
https://bugzilla.redhat.com/show_bug.cgi?id=633011

Weakness Enumeration

CWE-ID CWE Name Source
CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-3070
NVD Published Date:
09/28/2010
NVD Last Modified:
10/07/2010
Source:
Red Hat, Inc.