National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2010-3847 Detail

Current Description

elf/dl-load.c in ld.so in the GNU C Library (aka glibc or libc6) through 2.11.2, and 2.12.x through 2.12.1, does not properly handle a value of $ORIGIN for the LD_AUDIT environment variable, which allows local users to gain privileges via a crafted dynamic shared object (DSO) located in an arbitrary directory.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.9 MEDIUM
Vector: (AV:L/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.4


Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://seclists.org/fulldisclosure/2010/Oct/257 Exploit
http://seclists.org/fulldisclosure/2010/Oct/292
http://seclists.org/fulldisclosure/2010/Oct/294
http://security.gentoo.org/glsa/glsa-201011-01.xml
http://sourceware.org/ml/libc-hacker/2010-10/msg00007.html Patch
http://support.avaya.com/css/P8/documents/100120941
http://www.debian.org/security/2010/dsa-2122
http://www.kb.cert.org/vuls/id/537223 US Government Resource
http://www.mandriva.com/security/advisories?name=MDVSA-2010:207
http://www.redhat.com/support/errata/RHSA-2010-0872.html
http://www.securityfocus.com/archive/1/515545/100/0/threaded
http://www.securityfocus.com/bid/44154
http://www.ubuntu.com/usn/USN-1009-1
http://www.vmware.com/security/advisories/VMSA-2011-0001.html
http://www.vupen.com/english/advisories/2011/0025 Vendor Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=643306 Patch
https://lists.opensuse.org/opensuse-security-announce/2010-10/msg00007.html
https://rhn.redhat.com/errata/RHSA-2010-0787.html
https://www.exploit-db.com/exploits/44024/
https://www.exploit-db.com/exploits/44025/

Technical Details

Vulnerability Type (View All)

  • Improper Link Resolution Before File Access ('Link Following') (CWE-59)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:gnu:glibc:1.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.01:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.02:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.03:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.04:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.05:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.06:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.07:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.08:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.09:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:1.09.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.0.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.1.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.3.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.1.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.2.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.3.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.5.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.6.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.8:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.10.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.10.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.11.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.11.2
 cpe:2.3:a:gnu:glibc:2.12.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:gnu:glibc:2.12.1:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-3847
NVD Published Date:
01/07/2011
NVD Last Modified:
10/10/2018