National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2010-4015 Detail

Description

Buffer overflow in the gettoken function in contrib/intarray/_int_bool.c in the intarray array module in PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before 8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via integers with a large number of digits to unspecified functions.

Source:  MITRE
Description Last Modified:  02/01/2011

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.5 MEDIUM
Vector: (AV:N/AC:L/Au:S/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): Single
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.postgresql.org/gitweb?p=postgresql.git;a=commitdiff;h=7ccb6dc2d3e266a551827bb99179708580f72431 Patch
http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10705
http://lists.fedoraproject.org/pipermail/package-announce/2011-February/053817.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-February/053888.html
http://lists.opensuse.org/opensuse-security-announce/2011-04/msg00000.html
http://marc.info/?l=bugtraq&m=134124585221119&w=2
http://www.debian.org/security/2011/dsa-2157
http://www.mandriva.com/security/advisories?name=MDVSA-2011:021
http://www.postgresql.org/about/news.1289
http://www.postgresql.org/support/security
http://www.redhat.com/support/errata/RHSA-2011-0197.html
http://www.redhat.com/support/errata/RHSA-2011-0198.html
http://www.securityfocus.com/bid/46084
http://www.ubuntu.com/usn/USN-1058-1
http://www.vupen.com/english/advisories/2011/0262 Vendor Advisory
http://www.vupen.com/english/advisories/2011/0278
http://www.vupen.com/english/advisories/2011/0283
http://www.vupen.com/english/advisories/2011/0287
http://www.vupen.com/english/advisories/2011/0299
http://www.vupen.com/english/advisories/2011/0303
http://www.vupen.com/english/advisories/2011/0349
https://exchange.xforce.ibmcloud.com/vulnerabilities/65060

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:postgresql:postgresql:8.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.6:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.7:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.8:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.9:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.10:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.11:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.12:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.3.13:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:postgresql:postgresql:9.0:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:9.0.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:9.0.2:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:a:postgresql:postgresql:8.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.4.6:*:*:*:*:*:*:*
Configuration 4
OR
cpe:2.3:a:postgresql:postgresql:8.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.6:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.7:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.8:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.9:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.10:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.11:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.12:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.13:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.14:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.15:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.16:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.17:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.18:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.2.19:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-4015
NVD Published Date:
02/01/2011
NVD Last Modified:
08/16/2017