National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-1178 Detail

Description

Multiple integer overflows in the load_image function in file-pcx.c in the Personal Computer Exchange (PCX) plugin in GIMP 2.6.x and earlier allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PCX image that triggers a heap-based buffer overflow.

Source:  MITRE
Description Last Modified:  06/06/2011

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.gnome.org/browse/gimp/commit/?id=a9671395f6573e90316a9d748588c5435216f6ce Patch
http://security.gentoo.org/glsa/glsa-201209-23.xml
http://securitytracker.com/id?1025586
http://www.mandriva.com/security/advisories?name=MDVSA-2011:110
http://www.redhat.com/support/errata/RHSA-2011-0837.html
http://www.redhat.com/support/errata/RHSA-2011-0838.html
http://www.securityfocus.com/bid/48057
https://bugzilla.redhat.com/show_bug.cgi?id=689831 Patch
https://exchange.xforce.ibmcloud.com/vulnerabilities/67787

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:gnu:gimp:1.0.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:1.2.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.0.6:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.6:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.7:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.8:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.9:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.10:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.11:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.12:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.13:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.14:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.15:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.16:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.2.17:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.6:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.4.7:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.6:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.7:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.8:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.9:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:2.6.10:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gimp:*:*:*:*:*:*:*:*    versions up to (including) 2.6.11

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-1178
NVD Published Date:
06/06/2011
NVD Last Modified:
08/16/2017