National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-1487 Detail

Description

The (1) lc, (2) lcfirst, (3) uc, and (4) ucfirst functions in Perl 5.10.x, 5.11.x, and 5.12.x through 5.12.3, and 5.13.x through 5.13.11, do not apply the taint attribute to the return value upon processing tainted input, which might allow context-dependent attackers to bypass the taint protection mechanism via a crafted string.

Source:  MITRE
Description Last Modified:  04/11/2011

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/057891.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-April/057971.html
http://lists.opensuse.org/opensuse-security-announce/2011-05/msg00005.html
http://openwall.com/lists/oss-security/2011/04/01/3 Exploit Patch
http://openwall.com/lists/oss-security/2011/04/04/35 Exploit Patch
http://perl5.git.perl.org/perl.git/commit/539689e74a3bcb04d29e4cd9396de91a81045b99 Patch
http://rt.perl.org/rt3/Public/Bug/Display.html?id=87336 Exploit
http://www.debian.org/security/2011/dsa-2265
http://www.mandriva.com/security/advisories?name=MDVSA-2011:091
http://www.securityfocus.com/bid/47124 Exploit
https://bugzilla.redhat.com/show_bug.cgi?id=692844
https://bugzilla.redhat.com/show_bug.cgi?id=692898 Exploit Patch
https://exchange.xforce.ibmcloud.com/vulnerabilities/66528

Technical Details

Vulnerability Type (View All)

  • Permissions, Privileges, and Access Control (CWE-264)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:perl:perl:5.10.0:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.10.0:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.10.0:rc2:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.10.1:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.10.1:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.10.1:rc2:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:perl:perl:5.13.0:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.1:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.2:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.3:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.4:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.5:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.6:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.7:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.8:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.9:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.10:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.13.11:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:a:perl:perl:5.11.0:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.11.1:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.11.2:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.11.3:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.11.4:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.11.5:*:*:*:*:*:*:*
Configuration 4
OR
cpe:2.3:a:perl:perl:5.12.0:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc0:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc2:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc3:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc4:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.0:rc5:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.1:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.1:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.1:rc2:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.2:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.2:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.3:*:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.3:rc1:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.3:rc2:*:*:*:*:*:*
cpe:2.3:a:perl:perl:5.12.3:rc3:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-1487
NVD Published Date:
04/11/2011
NVD Last Modified:
08/16/2017