National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-2197 Detail

Description

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.

Source:  MITRE
Description Last Modified:  06/30/2011

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://groups.google.com/group/rubyonrails-security/msg/663b600d4471e0d4?dmode=source&output=gplain Patch
http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062514.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-June/062090.html
http://openwall.com/lists/oss-security/2011/06/09/2 Patch
http://openwall.com/lists/oss-security/2011/06/13/9 Patch
http://weblog.rubyonrails.org/2011/6/8/potential-xss-vulnerability-in-ruby-on-rails-applications Patch

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.1.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.1.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.1.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.2.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.2.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.2.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.9:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.10:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.3.11:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:beta:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:beta2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:beta3:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:beta4:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:rc:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.0:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.1:pre:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.2:pre:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.4:rc:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.4:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.5:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.6:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.6:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.6:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.7:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.7:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.7:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.8:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.8:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.8:rc3:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.0.8:rc4:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:a:rubyonrails:ruby_on_rails:3.1.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.1.0:beta1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:3.1.0:rc1:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-2197
NVD Published Date:
06/30/2011
NVD Last Modified:
07/06/2012