National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-3481 Detail

Description

The index_get_ids function in index.c in imapd in Cyrus IMAP Server before 2.4.11, when server-side threading is enabled, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted References header in an e-mail message.

Source:  MITRE      Last Modified:  09/14/2011

Evaluator Description

Per: http://cwe.mitre.org/data/definitions/476.html 'CWE-476: NULL Pointer Dereference'

Quick Info

CVE Dictionary Entry:
CVE-2011-3481
Original release date:
09/14/2011
Last revised:
12/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.3 MEDIUM
Vector:
(AV:N/AC:M/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
8.6
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Medium
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://bugzilla.cyrusimap.org/show_bug.cgi?id=2772 External Source CONFIRM http://bugzilla.cyrusimap.org/show_bug.cgi?id=2772
http://bugzilla.cyrusimap.org/show_bug.cgi?id=3463 External Source CONFIRM http://bugzilla.cyrusimap.org/show_bug.cgi?id=3463
http://git.cyrusimap.org/cyrus-imapd/commit/?id=6e776956a1a9dfa58eacdd0ddd52644009eac9e5 Patch External Source CONFIRM http://git.cyrusimap.org/cyrus-imapd/commit/?id=6e776956a1a9dfa58eacdd0ddd52644009eac9e5
http://www.mandriva.com/security/advisories?name=MDVSA-2012:037 External Source MANDRIVA MDVSA-2012:037
http://www.redhat.com/support/errata/RHSA-2011-1508.html External Source REDHAT RHSA-2011:1508
https://exchange.xforce.ibmcloud.com/vulnerabilities/69842 External Source XF cyrus-imap-indexgetids-dos(69842)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:cmu:cyrus_imap_server:2.0.17:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.1.16:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.1.17:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.1.18:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.8:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.9:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.10:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.11:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.12:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.13:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.2.13p1:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.0:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.1:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.2:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.3:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.4:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.5:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.6:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.7:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.8:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.9:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.10:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.11:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.12:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.12p1:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.12p2:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.13:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.14:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.15:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.16:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.3.17:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.0:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.1:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.2:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.3:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.4:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.5:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.6:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.7:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.8:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:2.4.9:*:*:*:*:*:*:*
cpe:2.3:a:cmu:cyrus_imap_server:*:*:*:*:*:*:*:*    versions up to (including) 2.4.10

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes