National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-4838 Detail

Current Description

JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.8 HIGH
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:C) (V2 legend)
Impact Subscore: 6.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://archives.neohapsis.com/archives/bugtraq/2011-12/0181.html
http://jruby.org/2011/12/27/jruby-1-6-5-1.html
http://rhn.redhat.com/errata/RHSA-2012-1232.html
http://security.gentoo.org/glsa/glsa-201207-06.xml
http://www.kb.cert.org/vuls/id/903934 US Government Resource
http://www.nruns.com/_downloads/advisory28122011.pdf
http://www.ocert.org/advisories/ocert-2011-003.html
https://exchange.xforce.ibmcloud.com/vulnerabilities/72019

Technical Details

Vulnerability Type (View All)

  • Improper Input Validation (CWE-20)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/a:jruby:jruby:0.9.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:0.9.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:0.9.2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:0.9.8
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:0.9.9
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.0:rc3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.0.3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1:b1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1:rc3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.4
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.5
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.6
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.1.6:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.2.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.2.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.2.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.3.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.3.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.3.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.3.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.4.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.4.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.4.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.4.0:rc3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.4.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.0:rc3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.4
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.5
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.5.6
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.0
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.0:rc1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.0:rc2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.0:rc3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.1
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.2
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.3
     Show Matching CPE(s)
 cpe:/a:jruby:jruby:1.6.4
     Show Matching CPE(s)
 cpe:/a:jruby:jruby
     Show Matching CPE(s)
Up to (including)
1.6.5


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-4838
NVD Published Date:
12/29/2011
NVD Last Modified:
08/28/2017