National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-4913 Detail

Current Description

The rose_parse_ccitt function in net/rose/rose_subr.c in the Linux kernel before 2.6.39 does not validate the FAC_CCITT_DEST_NSAP and FAC_CCITT_SRC_NSAP fields, which allows remote attackers to (1) cause a denial of service (integer underflow, heap memory corruption, and panic) via a small length value in data sent to a ROSE socket, or (2) conduct stack-based buffer overflow attacks via a large length value in data sent to a ROSE socket.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.8 HIGH
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:C) (V2 legend)
Impact Subscore: 6.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://ftp.osuosl.org/pub/linux/kernel/v2.6/ChangeLog-2.6.39 Broken Link
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=be20250c13f88375345ad99950190685eda51eb8 Patch
http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00020.html Third Party Advisory
http://www.openwall.com/lists/oss-security/2011/12/28/2
https://bugzilla.redhat.com/show_bug.cgi?id=770777 Issue Tracking VDB Entry
https://github.com/torvalds/linux/commit/be20250c13f88375345ad99950190685eda51eb8 Exploit Patch

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:novell:suse_linux_enterprise_server:10.0:sp4:*:*:ltss:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:o:linux:linux_kernel:2.6.38:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc5:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc6:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc7:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38:rc8:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:2.6.38.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.6.38.8


Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-4913
NVD Published Date:
06/21/2012
NVD Last Modified:
08/18/2016