National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2012-1823 Detail

Description

sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not properly handle query strings that lack an = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case.

Source:  MITRE      Last Modified:  05/11/2012

Quick Info

CVE Dictionary Entry:
CVE-2012-1823
Original release date:
05/11/2012
Last revised:
01/17/2018
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823/ Exploit External Source MISC http://eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823/
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03360041 External Source HP SSRT100877
http://lists.apple.com/archives/security-announce/2012/Sep/msg00004.html External Source APPLE APPLE-SA-2012-09-19-2
http://lists.opensuse.org/opensuse-security-announce/2012-05/msg00002.html External Source SUSE openSUSE-SU-2012:0590
http://lists.opensuse.org/opensuse-security-announce/2012-05/msg00007.html External Source SUSE SUSE-SU-2012:0598
http://lists.opensuse.org/opensuse-security-announce/2012-05/msg00011.html External Source SUSE SUSE-SU-2012:0604
http://marc.info/?l=bugtraq&m=134012830914727&w=2 External Source HP SSRT100856
http://rhn.redhat.com/errata/RHSA-2012-0546.html External Source REDHAT RHSA-2012:0546
http://rhn.redhat.com/errata/RHSA-2012-0547.html External Source REDHAT RHSA-2012:0547
http://rhn.redhat.com/errata/RHSA-2012-0568.html External Source REDHAT RHSA-2012:0568
http://rhn.redhat.com/errata/RHSA-2012-0569.html External Source REDHAT RHSA-2012:0569
http://rhn.redhat.com/errata/RHSA-2012-0570.html External Source REDHAT RHSA-2012:0570
http://support.apple.com/kb/HT5501 External Source CONFIRM http://support.apple.com/kb/HT5501
http://www.debian.org/security/2012/dsa-2465 External Source DEBIAN DSA-2465
http://www.kb.cert.org/vuls/id/520827 Exploit; US Government Resource External Source CERT-VN VU#520827
http://www.kb.cert.org/vuls/id/673343 US Government Resource External Source CERT-VN VU#673343
http://www.mandriva.com/security/advisories?name=MDVSA-2012:068 External Source MANDRIVA MDVSA-2012:068
http://www.php.net/archive/2012.php#id2012-05-03-1 External Source CONFIRM http://www.php.net/archive/2012.php#id2012-05-03-1
http://www.php.net/ChangeLog-5.php#5.4.2 Exploit; Patch External Source CONFIRM http://www.php.net/ChangeLog-5.php#5.4.2
http://www.securitytracker.com/id?1027022 External Source SECTRACK 1027022
https://bugs.php.net/bug.php?id=61910 Exploit; Patch External Source CONFIRM https://bugs.php.net/bug.php?id=61910
https://bugs.php.net/patch-display.php?bug_id=61910&patch=cgi.diff&revision=1335984315&display=1 External Source CONFIRM https://bugs.php.net/patch-display.php?bug_id=61910&patch=cgi.diff&revision=1335984315&display=1

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:beta1:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:beta2:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:beta3:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:beta4:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:rc1:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:rc2:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.0:rc3:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.0:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.1:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.2:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.3:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.4:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.5:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.1.6:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.0:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.1:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.2:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.3:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.4:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.5:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.6:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.7:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.8:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.9:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.10:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.11:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.12:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.13:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.14:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.15:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.16:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.2.17:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.0:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.1:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.2:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.3:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.4:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.5:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.6:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.7:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.8:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.9:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.3.10:*:*:*:*:*:*:*
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.3.11
Configuration 2
OR
cpe:2.3:a:php:php:5.4.0:*:*:*:*:*:*:*
cpe:2.3:a:php:php:5.4.1:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes