National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2012-6081 Detail

Description

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

Source:  MITRE
Description Last Modified:  01/02/2013

Evaluator Description

Per: http://cwe.mitre.org/data/definitions/434.html 'CWE-434: Unrestricted Upload of File with Dangerous Type'

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.0 MEDIUM
Vector: (AV:N/AC:M/Au:S/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://hg.moinmo.in/moin/1.9/rev/7e7e1cbb9d3f Exploit Patch
http://moinmo.in/MoinMoinRelease1.9
http://moinmo.in/SecurityFixes Vendor Advisory
http://ubuntu.com/usn/usn-1680-1
http://www.debian.org/security/2012/dsa-2593
http://www.exploit-db.com/exploits/25304
http://www.openwall.com/lists/oss-security/2012/12/29/6
http://www.openwall.com/lists/oss-security/2012/12/30/4
http://www.securityfocus.com/bid/57082
https://bugs.launchpad.net/ubuntu/+source/moin/+bug/1094599

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:moinmo:moinmoin:0.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.5:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.6:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.7:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.8:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.9:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.10:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:0.11:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.2.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.2.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.2.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.2.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.5:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.3.5:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta3:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta4:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta5:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:beta6:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.0:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.3:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.3:rc2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.5:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.5:a:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.5:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.5a:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.6:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.7:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.5.8:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.0:beta1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.0:beta2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.0:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.0:rc2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.6.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:beta1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:beta2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:rc1:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:rc2:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.0:rc3:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.7.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.6:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.7:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.8.8:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.9.0:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.9.1:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.9.2:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.9.3:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:1.9.4:*:*:*:*:*:*:*
cpe:2.3:a:moinmo:moinmoin:*:*:*:*:*:*:*:*    versions up to (including) 1.9.5

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2012-6081
NVD Published Date:
01/02/2013
NVD Last Modified:
12/13/2013