CVE-2013-0211 Detail

Current Description

Integer signedness error in the archive_write_zip_data function in archive_write_set_format_zip.c in libarchive 3.1.2 and earlier, when running on 64-bit machines, allows context-dependent attackers to cause a denial of service (crash) via unspecified vectors, which triggers an improper conversion between unsigned and signed types, leading to a buffer overflow.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101687.html Third Party Advisory 
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101700.html Third Party Advisory 
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101872.html Third Party Advisory 
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101876.html Third Party Advisory 
http://lists.opensuse.org/opensuse-updates/2015-03/msg00065.html Third Party Advisory 
http://www.mandriva.com/security/advisories?name=MDVSA-2013:147 Third Party Advisory 
http://www.securityfocus.com/bid/58926
http://www.securitytracker.com/id/1035995 Third Party Advisory  VDB Entry 
http://www.ubuntu.com/usn/USN-2549-1 Third Party Advisory 
https://bugzilla.redhat.com/show_bug.cgi?id=902998 Issue Tracking  Patch 
https://github.com/libarchive/libarchive/commit/22531545514043e04633e1c015c7540b9de9dbe4 Patch 
https://www.freebsd.org/security/advisories/FreeBSD-SA-16:23.libarchive.asc Third Party Advisory 

Weakness Enumeration

CWE-ID CWE Name Source
CWE-189 Numeric Errors cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

10 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2013-0211
NVD Published Date:
09/30/2013
NVD Last Modified:
10/30/2018
Source:
MITRE