National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-0193 Detail

Description

WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.

Source:  MITRE
Description Last Modified:  05/06/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://netty.io/news/2014/04/30/release-day.html Patch Vendor Advisory
http://rhn.redhat.com/errata/RHSA-2014-1019.html
http://rhn.redhat.com/errata/RHSA-2014-1020.html
http://rhn.redhat.com/errata/RHSA-2014-1021.html
http://rhn.redhat.com/errata/RHSA-2014-1351.html
http://rhn.redhat.com/errata/RHSA-2015-0675.html
http://rhn.redhat.com/errata/RHSA-2015-0720.html
http://rhn.redhat.com/errata/RHSA-2015-0765.html
http://secunia.com/advisories/59290
http://www.securityfocus.com/bid/67182
https://github.com/netty/netty/issues/2441

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:netty_project:netty:3.6.0:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.1:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.2:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.3:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.4:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.5:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.6:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.7:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.6.8:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.7.0:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.8.0:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.8.1:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:3.9.0:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.0:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.1:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.2:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.3:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.4:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.5:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.6:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.7:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.8:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.9:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.10:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.11:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.12:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.13:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.14:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.15:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.16:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.17:*:*:*:*:*:*:*
cpe:2.3:a:netty_project:netty:4.0.18:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-0193
NVD Published Date:
05/06/2014
NVD Last Modified:
01/06/2017