National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-7819 Detail

Description

Multiple directory traversal vulnerabilities in server.rb in Sprockets before 2.0.5, 2.1.x before 2.1.4, 2.2.x before 2.2.3, 2.3.x before 2.3.3, 2.4.x before 2.4.6, 2.5.x before 2.5.1, 2.6.x and 2.7.x before 2.7.1, 2.8.x before 2.8.3, 2.9.x before 2.9.4, 2.10.x before 2.10.2, 2.11.x before 2.11.3, 2.12.x before 2.12.3, and 3.x before 3.0.0.beta.3, as distributed with Ruby on Rails 3.x and 4.x, allow remote attackers to determine the existence of files outside the application root via a ../ (dot dot slash) sequence with (1) double slashes or (2) URL encoding.

Source:  MITRE
Description Last Modified:  11/08/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:P/I:N/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): None
Availability (A): None
Additional Information:
Allows unauthorized disclosure of information

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-updates/2014-11/msg00103.html
http://lists.opensuse.org/opensuse-updates/2014-11/msg00105.html
http://lists.opensuse.org/opensuse-updates/2014-11/msg00110.html
http://lists.opensuse.org/opensuse-updates/2014-11/msg00111.html
https://groups.google.com/forum/message/raw?msg=rubyonrails-security/doAVp0YaTqY/aHFngBqNBoAJ
https://groups.google.com/forum/message/raw?msg=rubyonrails-security/wQBeGXqGs3E/JqUMB6fhh3gJ

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.0.5
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.1.3
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.2.2
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.3.2
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.4.5
cpe:2.3:a:sprockets_project:sprockets:2.5.0:*:*:*:*:*:*:*
cpe:2.3:a:sprockets_project:sprockets:2.6.0:*:*:*:*:*:*:*
cpe:2.3:a:sprockets_project:sprockets:2.7.0:*:*:*:*:*:*:*
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.8.2
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.9.3
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.10.1
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.11.2
cpe:2.3:a:sprockets_project:sprockets:*:*:*:*:*:*:*:*    versions up to (including) 2.12.2
cpe:2.3:a:sprockets_project:sprockets:3.0.0:beta.2:*:*:*:*:*:*
OR
cpe:2.3:a:rubyonrails:ruby_on_rails:*:*:*:*:*:*:*:*    versions up to (including) 3.2.17
cpe:2.3:a:rubyonrails:ruby_on_rails:*:*:*:*:*:*:*:*    versions up to (including) 4.1.7

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-7819
NVD Published Date:
11/08/2014
NVD Last Modified:
12/02/2014