National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-8104 Detail

Description

OpenVPN 2.x before 2.0.11, 2.1.x, 2.2.x before 2.2.3, and 2.3.x before 2.3.6 allows remote authenticated users to cause a denial of service (server crash) via a small control channel packet.

Source:  MITRE
Description Last Modified:  12/03/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:L/Au:S/C:N/I:N/A:C) (V2 legend)
Impact Subscore: 6.9
Exploitability Subscore: 8.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://advisories.mageia.org/MGASA-2014-0512.html Third Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00008.html Third Party Advisory
http://www.debian.org/security/2014/dsa-3084 Third Party Advisory
http://www.mandriva.com/security/advisories?name=MDVSA-2015:139 Broken Link
http://www.ubuntu.com/usn/USN-2430-1 Third Party Advisory
https://community.openvpn.net/openvpn/wiki/SecurityAnnouncement-97597e732b Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:mageia:mageia:4.0:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:o:novell:opensuse:12.3:*:*:*:*:*:*:*
cpe:2.3:o:novell:opensuse:13.1:*:*:*:*:*:*:*
cpe:2.3:o:novell:opensuse:13.2:*:*:*:*:*:*:*
Configuration 4
OR
cpe:2.3:a:openvpn:openvpn:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc2:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc3:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc4:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc5:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc6:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.1_rc7:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.2:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.2_rc1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.3:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.3_rc1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.4:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.5:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.6:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.6_rc1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.7:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.8:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.9:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0.10:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc2:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc3:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc4:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc5:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc6:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc7:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc8:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc9:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc10:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc11:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc12:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc13:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc14:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc15:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc16:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc17:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc18:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc19:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc20:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_rc21:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test1:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test2:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test3:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test4:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test5:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test6:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test7:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test8:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test9:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test10:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test11:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test12:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test14:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test15:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test16:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test17:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test18:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test19:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test20:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test21:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test22:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test23:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test24:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test25:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test26:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test27:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test28:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.0_test29:*:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-1:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-10:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-11:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-12:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-13:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-14:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-15:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-16:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-2:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-3:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-4:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-5:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-6:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-7:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-8:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:beta-9:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_1:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_10:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_11:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_12:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_13:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_14:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_15:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_16:*:*:*:*:*:*
cpe:2.3:a:openvpn:openvpn:2.1:rc_17:*:*:*:*:*:*
Configuration 5
Showing 100 of 142 CPEs, view all CPEs here.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-8104
NVD Published Date:
12/03/2014
NVD Last Modified:
08/29/2016