National Vulnerability Database

National Vulnerability Database

National Vulnerability

CVE-2014-9028 Detail


Heap-based buffer overflow in stream_decoder.c in libFLAC before 1.3.1 allows remote attackers to execute arbitrary code via a crafted .flac file.

Source:  MITRE      Last Modified:  11/26/2014

Quick Info

CVE Dictionary Entry:
Original release date:
Last revised:


CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
Exploitability Subscore:
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to

Hyperlink Resource Type Source Name External Source CONFIRM External Source SUSE openSUSE-SU-2014:1588 External Source MISC External Source REDHAT RHSA-2015:0767 External Source DEBIAN DSA-3082 External Source MANDRIVA MDVSA-2014:239 External Source MANDRIVA MDVSA-2015:188 US Government Resource External Source MISC External Source CONFIRM External Source BUGTRAQ 20141125 [oCERT 2014-008] libFLAC multiple issues External Source BID 71282 External Source UBUNTU USN-2426-1;a=commit;h=fcf0ba06ae12ccd7c67cee3c8d948df15f946b85 External Source CONFIRM;a=commit;h=fcf0ba06ae12ccd7c67cee3c8d948df15f946b85

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
cpe:2.3:a:flac:libflac:*:*:*:*:*:*:*:*    versions up to (including) 1.3.0

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 8 change records found - show changes