National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-0224 Detail

Current Description

qpidd in Apache Qpid 0.30 and earlier allows remote attackers to cause a denial of service (daemon crash) via a crafted protocol sequence set. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-0203.

Source:  MITRE      Last Modified:  10/30/2017      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2015-0224
Original release date:
10/30/2017
Last revised:
01/04/2018
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
7.5 High
Vector:
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H (legend)
Impact Score:
3.6
Exploitability Score:
3.9
CVSS Version 3 Metrics:
Attack Vector (AV):
Network
Attack Complexity (AC):
Low
Privileges Required (PR):
None
User Interaction (UI):
None
Scope (S):
Unchanged
Confidentiality (C):
None
Integrity (I):
None
Availability (A):
High
CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178606.html Issue Tracking; Third Party Advisory External Source FEDORA FEDORA-2016-120b194a75
http://mail-archives.apache.org/mod_mbox/www-announce/201501.mbox/%3C54C60497.5060504@apache.org%3E Issue Tracking; Vendor Advisory External Source MLIST [www-announce] 20150126 CVE-2015-0224: qpidd can be crashed by unauthenticated user
http://packetstormsecurity.com/files/130105/Apache-Qpid-0.30-Crash.html Issue Tracking; Third Party Advisory; VDB Entry External Source MISC http://packetstormsecurity.com/files/130105/Apache-Qpid-0.30-Crash.html
http://rhn.redhat.com/errata/RHSA-2015-0660.html Issue Tracking; Third Party Advisory External Source REDHAT RHSA-2015:0660
http://rhn.redhat.com/errata/RHSA-2015-0661.html Issue Tracking; Third Party Advisory External Source REDHAT RHSA-2015:0661
http://rhn.redhat.com/errata/RHSA-2015-0662.html Issue Tracking; Third Party Advisory External Source REDHAT RHSA-2015:0662
http://rhn.redhat.com/errata/RHSA-2015-0707.html Issue Tracking; Third Party Advisory External Source REDHAT RHSA-2015:0707
http://www.securityfocus.com/archive/1/archive/1/534545/100/0/threaded Issue Tracking; Third Party Advisory; VDB Entry External Source BUGTRAQ 20150126 CVE-2015-0224: qpidd can be crashed by unauthenticated user
http://www.securityfocus.com/bid/72317 Issue Tracking; Third Party Advisory; VDB Entry External Source BID 72317
http://www.securitytracker.com/id/1031872 Issue Tracking; Third Party Advisory; VDB Entry External Source SECTRACK 1031872
https://access.redhat.com/errata/RHBA-2016:1500 External Source REDHAT RHBA-2016:1500
https://access.redhat.com/errata/RHSA-2015:0708 Issue Tracking; Third Party Advisory External Source REDHAT RHSA-2015:0708
https://bugzilla.redhat.com/show_bug.cgi?id=1186302 Issue Tracking; Third Party Advisory External Source CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=1186302
https://issues.apache.org/jira/browse/QPID-6310 Issue Tracking; Patch; Vendor Advisory External Source CONFIRM https://issues.apache.org/jira/browse/QPID-6310

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:apache:qpid:*:*:*:*:*:*:*:*    versions up to (including) 0.30

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes