National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-4026 Detail

Description

The pcntl_exec implementation in PHP before 5.4.41, 5.5.x before 5.5.25, and 5.6.x before 5.6.9 truncates a pathname upon encountering a \x00 character, which might allow remote attackers to bypass intended extension restrictions and execute files with unexpected names via a crafted first argument. NOTE: this vulnerability exists because of an incomplete fix for CVE-2006-7243.

Source:  MITRE
Description Last Modified:  06/09/2015

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/158616.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/158915.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-May/159031.html
http://lists.opensuse.org/opensuse-updates/2015-06/msg00002.html
http://php.net/ChangeLog-5.php Patch
http://rhn.redhat.com/errata/RHSA-2015-1135.html
http://rhn.redhat.com/errata/RHSA-2015-1186.html
http://rhn.redhat.com/errata/RHSA-2015-1187.html
http://rhn.redhat.com/errata/RHSA-2015-1218.html
http://rhn.redhat.com/errata/RHSA-2015-1219.html
http://www.debian.org/security/2015/dsa-3280
http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
http://www.securityfocus.com/bid/75056
http://www.securitytracker.com/id/1032431
https://bugs.php.net/bug.php?id=68598 Exploit Patch
https://security.gentoo.org/glsa/201606-10
https://support.apple.com/kb/HT205031

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/o:redhat:enterprise_linux:6
cpe:/o:redhat:enterprise_linux:7.0
Configuration 2
OR
cpe:/a:php:php:5.4.39
cpe:/a:php:php    versions up to (including) 5.4.40
cpe:/a:php:php:5.5.0
cpe:/a:php:php:5.5.0:alpha1
cpe:/a:php:php:5.5.0:alpha2
cpe:/a:php:php:5.5.0:alpha3
cpe:/a:php:php:5.5.0:alpha4
cpe:/a:php:php:5.5.0:alpha5
cpe:/a:php:php:5.5.0:alpha6
cpe:/a:php:php:5.5.0:beta1
cpe:/a:php:php:5.5.0:beta2
cpe:/a:php:php:5.5.0:beta3
cpe:/a:php:php:5.5.0:beta4
cpe:/a:php:php:5.5.0:rc1
cpe:/a:php:php:5.5.0:rc2
cpe:/a:php:php:5.5.1
cpe:/a:php:php:5.5.2
cpe:/a:php:php:5.5.3
cpe:/a:php:php:5.5.4
cpe:/a:php:php:5.5.5
cpe:/a:php:php:5.5.6
cpe:/a:php:php:5.5.7
cpe:/a:php:php:5.5.8
cpe:/a:php:php:5.5.9
cpe:/a:php:php:5.5.10
cpe:/a:php:php:5.5.11
cpe:/a:php:php:5.5.12
cpe:/a:php:php:5.5.13
cpe:/a:php:php:5.5.14
cpe:/a:php:php:5.5.18
cpe:/a:php:php:5.5.19
cpe:/a:php:php:5.5.20
cpe:/a:php:php:5.5.21
cpe:/a:php:php:5.5.22
cpe:/a:php:php:5.5.23
cpe:/a:php:php:5.5.24
cpe:/a:php:php:5.6.0:alpha1
cpe:/a:php:php:5.6.0:alpha2
cpe:/a:php:php:5.6.0:alpha3
cpe:/a:php:php:5.6.0:alpha4
cpe:/a:php:php:5.6.0:alpha5
cpe:/a:php:php:5.6.0:beta1
cpe:/a:php:php:5.6.0:beta2
cpe:/a:php:php:5.6.0:beta3
cpe:/a:php:php:5.6.0:beta4
cpe:/a:php:php:5.6.2
cpe:/a:php:php:5.6.3
cpe:/a:php:php:5.6.4
cpe:/a:php:php:5.6.5
cpe:/a:php:php:5.6.6
cpe:/a:php:php:5.6.7
cpe:/a:php:php:5.6.8
Configuration 3
OR
cpe:/o:apple:mac_os_x    versions up to (including) 10.10.4
Configuration 4
OR
cpe:/o:redhat:enterprise_linux_desktop:7.0
cpe:/o:redhat:enterprise_linux_hpc_node:7.0
cpe:/o:redhat:enterprise_linux_hpc_node_eus:7.1
cpe:/o:redhat:enterprise_linux_server:7.0
cpe:/o:redhat:enterprise_linux_server_eus:7.1
cpe:/o:redhat:enterprise_linux_workstation:7.0

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

14 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-4026
NVD Published Date:
06/09/2015
NVD Last Modified:
01/04/2018