National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-4335 Detail

Current Description

Redis before 2.8.21 and 3.x before 3.0.2 allows remote attackers to execute arbitrary Lua bytecode via the eval command.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://benmmurphy.github.io/blog/2015/06/04/redis-eval-lua-sandbox-escape/ Exploit Third Party Advisory
http://lists.fedoraproject.org/pipermail/package-announce/2015-July/162094.html Third Party Advisory
http://lists.fedoraproject.org/pipermail/package-announce/2015-July/162146.html Third Party Advisory
http://lists.opensuse.org/opensuse-updates/2015-10/msg00014.html Third Party Advisory
http://rhn.redhat.com/errata/RHSA-2015-1676.html Third Party Advisory
http://www.debian.org/security/2015/dsa-3279 Third Party Advisory
http://www.openwall.com/lists/oss-security/2015/06/04/12 Mailing List Third Party Advisory
http://www.openwall.com/lists/oss-security/2015/06/04/8 Mailing List Third Party Advisory
http://www.openwall.com/lists/oss-security/2015/06/05/3 Mailing List Third Party Advisory
http://www.securityfocus.com/bid/75034 Third Party Advisory VDB Entry
https://github.com/antirez/redis/commit/fdf9d455098f54f7666c702ae464e6ea21e25411 Third Party Advisory
https://groups.google.com/forum/#!msg/redis-db/4Y6OqK8gEyk/Dg-5cejl-eUJ
https://security.gentoo.org/glsa/201702-16 Third Party Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-17 DEPRECATED: Code NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:redislabs:redis:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.8.20
 cpe:2.3:a:redislabs:redis:3.0.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:redislabs:redis:3.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

12 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-4335
NVD Published Date:
06/09/2015
NVD Last Modified:
08/13/2018