CVE-2016-0729 Detail

Current Description

Multiple buffer overflows in (1) internal/XMLReader.cpp, (2) util/XMLURL.cpp, and (3) util/XMLUri.cpp in the XML Parser library in Apache Xerces-C before 3.1.3 allow remote attackers to cause a denial of service (segmentation fault or memory corruption) or possibly execute arbitrary code via a crafted document.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  9.8 CRITICAL
Vector:  CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have published a CVSS score for this CVE based on publicly available information at the time of analysis. The CNA has not provided a score within the CVE List.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182062.html Third Party Advisory 
http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182131.html Third Party Advisory 
http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182597.html Third Party Advisory 
http://lists.opensuse.org/opensuse-updates/2016-04/msg00012.html
http://lists.opensuse.org/opensuse-updates/2016-04/msg00086.html
http://lists.opensuse.org/opensuse-updates/2016-07/msg00053.html
http://packetstormsecurity.com/files/135949/Apache-Xerces-C-XML-Parser-Buffer-Overflow.html
http://svn.apache.org/viewvc?view=revision&revision=1727978
http://www.debian.org/security/2016/dsa-3493 Third Party Advisory 
http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
http://www.securityfocus.com/archive/1/537620/100/0/threaded
http://www.securityfocus.com/bid/83423
http://www.securitytracker.com/id/1035113
http://xerces.apache.org/xerces-c/secadv/CVE-2016-0729.txt Vendor Advisory 
https://issues.apache.org/jira/browse/XERCESC-2061 Vendor Advisory 
https://security.gentoo.org/glsa/201612-46
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

13 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-0729
NVD Published Date:
04/07/2016
NVD Last Modified:
10/16/2018
Source:
Red Hat, Inc.