National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-0753 Detail

Description

Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

Source:  MITRE
Description Last Modified:  02/15/2016

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 5.3 MEDIUM
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N (V3 legend)
Impact Score: 1.4
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): Low
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178041.html
http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178043.html
http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178047.html
http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178065.html
http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178066.html
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00053.html
http://lists.opensuse.org/opensuse-updates/2016-02/msg00043.html
http://rhn.redhat.com/errata/RHSA-2016-0296.html
http://www.debian.org/security/2016/dsa-3464
http://www.openwall.com/lists/oss-security/2016/01/25/14
http://www.securityfocus.com/bid/82247
http://www.securitytracker.com/id/1034816
https://groups.google.com/forum/message/raw?msg=ruby-security-ann/6jQVC1geukQ/3Iy0GU1ZEgAJ

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.0:-:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.0:beta1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.2:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.2:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.2:rc3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.6:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.8:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.12:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.13:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.1.14:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:beta1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:beta2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:beta3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:beta4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.0:rc3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.1:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.1:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.1:rc3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.1:rc4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.3:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.4:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.5:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:4.2.5:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:rubyonrails:ruby_on_rails:5.0.0:beta1:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

6 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-0753
NVD Published Date:
02/15/2016
NVD Last Modified:
09/09/2017