National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-6564 Detail

Current Description

Android devices with code from Ragentek contain a privileged binary that performs over-the-air (OTA) update checks. Additionally, there are multiple techniques used to hide the execution of this binary. This behavior could be described as a rootkit. This binary, which resides as /system/bin/debugs, runs with root privileges and does not communicate over an encrypted channel. The binary has been shown to communicate with three hosts via HTTP: oyag[.]lhzbdvm[.]com oyag[.]prugskh[.]net oyag[.]prugskh[.]com Server responses to requests sent by the debugs binary include functionalities to execute arbitrary commands as root, install applications, or update configurations. Examples of a request sent by the client binary: POST /pagt/agent?data={"name":"c_regist","details":{...}} HTTP/1. 1 Host: 114.80.68.223 Connection: Close An example response from the server could be: HTTP/1.1 200 OK {"code": "01", "name": "push_commands", "details": {"server_id": "1" , "title": "Test Command", "comments": "Test", "commands": "touch /tmp/test"}} This binary is reported to be present in the following devices: BLU Studio G BLU Studio G Plus BLU Studio 6.0 HD BLU Studio X BLU Studio X Plus BLU Studio C HD Infinix Hot X507 Infinix Hot 2 X510 Infinix Zero X506 Infinix Zero 2 X509 DOOGEE Voyager 2 DG310 LEAGOO Lead 5 LEAGOO Lead 6 LEAGOO Lead 3i LEAGOO Lead 2S LEAGOO Alfa 6 IKU Colorful K45i Beeline Pro 2 XOLO Cube 5.0

Source:  MITRE
Description Last Modified:  07/13/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 8.1 HIGH
Vector: AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 2.2


Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://www.bitsighttech.com/blog/ragentek-android-ota-update-mechanism-vulnerable-to-mitm-attack Exploit Third Party Advisory
https://www.kb.cert.org/vuls/id/624539 Third Party Advisory US Government Resource
https://www.securityfocus.com/bid/94393/ Third Party Advisory VDB Entry

Technical Details

Vulnerability Type (View All)

  • Permissions, Privileges, and Access Control (CWE-264)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:o:infinixauthority:hot_x507_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:infinixauthority:hot_x507:-:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:o:infinixauthority:hot_2_x510_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:infinixauthority:hot_2_x510:-:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:o:infinixauthority:zero_x506_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:infinixauthority:zero_x506:-:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:o:infinixauthority:zero_2_x509_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:infinixauthority:zero_2_x509:-:*:*:*:*:*:*:*
Configuration 5
AND
OR
cpe:2.3:o:bluproducts:studio_g_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_g:-:*:*:*:*:*:*:*
Configuration 6
AND
OR
cpe:2.3:o:bluproducts:studio_g_plus_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_g_plus:-:*:*:*:*:*:*:*
Configuration 7
AND
OR
cpe:2.3:o:bluproducts:studio_6.0_hd_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_6.0_hd:-:*:*:*:*:*:*:*
Configuration 8
AND
OR
cpe:2.3:o:bluproducts:studio_x_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_x:-:*:*:*:*:*:*:*
Configuration 9
AND
OR
cpe:2.3:o:bluproducts:studio_x_plus_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_x_plus:-:*:*:*:*:*:*:*
Configuration 10
AND
OR
cpe:2.3:o:bluproducts:studio_c_hd_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:bluproducts:studio_c_hd:-:*:*:*:*:*:*:*
Configuration 11
AND
OR
cpe:2.3:o:xolo:cube_5.0_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:xolo:cube_5.0:-:*:*:*:*:*:*:*
Configuration 12
AND
OR
cpe:2.3:o:beeline:pro_2_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:beeline:pro_2:-:*:*:*:*:*:*:*
Configuration 13
AND
OR
cpe:2.3:o:iku-mobile:colorful_k45i_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:iku-mobile:colorful_k45i:-:*:*:*:*:*:*:*
Configuration 14
AND
OR
cpe:2.3:o:leagoo:lead_5_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:leagoo:lead_5:-:*:*:*:*:*:*:*
Configuration 15
AND
OR
cpe:2.3:o:leagoo:lead_6_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:leagoo:lead_6:-:*:*:*:*:*:*:*
Configuration 16
AND
OR
cpe:2.3:o:leagoo:lead_3i_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:leagoo:lead_3i:-:*:*:*:*:*:*:*
Configuration 17
AND
OR
cpe:2.3:o:leagoo:lead_2s_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:leagoo:lead_2s:-:*:*:*:*:*:*:*
Configuration 18
AND
OR
cpe:2.3:o:leagoo:alfa_6_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:leagoo:alfa_6:-:*:*:*:*:*:*:*
Configuration 19
AND
OR
cpe:2.3:o:doogee:voyager_2_dg310i_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:doogee:voyager_2_dg310i:-:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-6564
NVD Published Date:
07/13/2018
NVD Last Modified:
09/14/2018