National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-9587 Detail

Current Description

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Source:  MITRE
Description Last Modified:  04/24/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 8.1 HIGH
Vector: AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 2.2


Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://rhn.redhat.com/errata/RHSA-2017-0195.html Third Party Advisory
http://rhn.redhat.com/errata/RHSA-2017-0260.html Third Party Advisory
http://www.securityfocus.com/bid/95352 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2017:0448 Third Party Advisory
https://access.redhat.com/errata/RHSA-2017:0515 Third Party Advisory
https://access.redhat.com/errata/RHSA-2017:1685 Third Party Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9587 Issue Tracking Third Party Advisory
https://security.gentoo.org/glsa/201701-77 Third Party Advisory
https://www.exploit-db.com/exploits/41013/ Exploit Third Party Advisory VDB Entry

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:ansible:ansible:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
2.1.4

Configuration 2 ( hide )
 cpe:2.3:a:ansible:ansible:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
2.2.1

Configuration 3 ( hide )
 cpe:2.3:a:redhat:openstack:11.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-9587
NVD Published Date:
04/24/2018
NVD Last Modified:
06/06/2018