National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-13082 Detail

Current Description

Wi-Fi Protected Access (WPA and WPA2) that supports IEEE 802.11r allows reinstallation of the Pairwise Transient Key (PTK) Temporal Key (TK) during the fast BSS transmission (FT) handshake, allowing an attacker within radio range to replay, decrypt, or spoof frames.

Source:  MITRE      Last Modified:  10/17/2017      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2017-13082
Original release date:
10/17/2017
Last revised:
01/18/2018
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
8.1 High
Vector:
CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N (legend)
Impact Score:
5.2
Exploitability Score:
2.8
CVSS Version 3 Metrics:
Attack Vector (AV):
Adjacent
Attack Complexity (AC):
Low
Privileges Required (PR):
None
User Interaction (UI):
None
Scope (S):
Unchanged
Confidentiality (C):
High
Integrity (I):
High
Availability (A):
None
CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.8 MEDIUM
Vector:
(AV:A/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
6.5
CVSS Version 2 Metrics:
Access Vector:
Local network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-007.txt Third Party Advisory External Source CONFIRM http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-007.txt
http://www.debian.org/security/2017/dsa-3999 Third Party Advisory External Source DEBIAN DSA-3999
http://www.kb.cert.org/vuls/id/228519 Third Party Advisory; US Government Resource External Source CERT-VN VU#228519
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html External Source CONFIRM http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
http://www.securityfocus.com/bid/101274 Third Party Advisory; VDB Entry External Source BID 101274
http://www.securitytracker.com/id/1039570 Third Party Advisory; VDB Entry External Source SECTRACK 1039570
http://www.securitytracker.com/id/1039571 Third Party Advisory; VDB Entry External Source SECTRACK 1039571
http://www.securitytracker.com/id/1039573 Third Party Advisory; VDB Entry External Source SECTRACK 1039573
http://www.securitytracker.com/id/1039581 Third Party Advisory; VDB Entry External Source SECTRACK 1039581
http://www.ubuntu.com/usn/USN-3455-1 Third Party Advisory External Source UBUNTU USN-3455-1
https://access.redhat.com/errata/RHSA-2017:2907 Third Party Advisory External Source REDHAT RHSA-2017:2907
https://access.redhat.com/security/vulnerabilities/kracks Third Party Advisory External Source CONFIRM https://access.redhat.com/security/vulnerabilities/kracks
https://github.com/vanhoefm/krackattacks-test-ap-ft Exploit; Third Party Advisory External Source MISC https://github.com/vanhoefm/krackattacks-test-ap-ft
https://security.FreeBSD.org/advisories/FreeBSD-SA-17:07.wpa.asc Third Party Advisory External Source FREEBSD FreeBSD-SA-17:07
https://security.gentoo.org/glsa/201711-03 External Source GENTOO GLSA-201711-03
https://source.android.com/security/bulletin/2017-11-01 External Source CONFIRM https://source.android.com/security/bulletin/2017-11-01
https://support.lenovo.com/us/en/product_security/LEN-17420 Third Party Advisory External Source CONFIRM https://support.lenovo.com/us/en/product_security/LEN-17420
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171016-wpa Third Party Advisory External Source CISCO 20171016 Multiple Vulnerabilities in Wi-Fi Protected Access and Wi-Fi Protected Access II
https://w1.fi/security/2017-1/wpa-packet-number-reuse-with-replayed-messages.txt Third Party Advisory External Source MISC https://w1.fi/security/2017-1/wpa-packet-number-reuse-with-replayed-messages.txt
https://www.krackattacks.com/ Technical Description; Third Party Advisory External Source MISC https://www.krackattacks.com/

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
cpe:/o:canonical:ubuntu_linux:17.04
cpe:/o:debian:debian_linux:8.0
cpe:/o:debian:debian_linux:9.0
cpe:/o:freebsd:freebsd
cpe:/o:freebsd:freebsd:10
cpe:/o:freebsd:freebsd:10.4
cpe:/o:freebsd:freebsd:11
cpe:/o:freebsd:freebsd:11.1
cpe:/o:opensuse:leap:42.2
cpe:/o:opensuse:leap:42.3
cpe:/o:redhat:enterprise_linux_desktop:7
cpe:/o:redhat:enterprise_linux_server:7
Configuration 2
OR
cpe:/a:w1.fi:hostapd:0.2.4
cpe:/a:w1.fi:hostapd:0.2.5
cpe:/a:w1.fi:hostapd:0.2.6
cpe:/a:w1.fi:hostapd:0.2.8
cpe:/a:w1.fi:hostapd:0.3.7
cpe:/a:w1.fi:hostapd:0.3.9
cpe:/a:w1.fi:hostapd:0.3.10
cpe:/a:w1.fi:hostapd:0.3.11
cpe:/a:w1.fi:hostapd:0.4.7
cpe:/a:w1.fi:hostapd:0.4.8
cpe:/a:w1.fi:hostapd:0.4.9
cpe:/a:w1.fi:hostapd:0.4.10
cpe:/a:w1.fi:hostapd:0.4.11
cpe:/a:w1.fi:hostapd:0.5.7
cpe:/a:w1.fi:hostapd:0.5.8
cpe:/a:w1.fi:hostapd:0.5.9
cpe:/a:w1.fi:hostapd:0.5.10
cpe:/a:w1.fi:hostapd:0.5.11
cpe:/a:w1.fi:hostapd:0.6.8
cpe:/a:w1.fi:hostapd:0.6.9
cpe:/a:w1.fi:hostapd:0.6.10
cpe:/a:w1.fi:hostapd:0.7.3
cpe:/a:w1.fi:hostapd:1.0
cpe:/a:w1.fi:hostapd:1.1
cpe:/a:w1.fi:hostapd:2.0
cpe:/a:w1.fi:hostapd:2.1
cpe:/a:w1.fi:hostapd:2.2
cpe:/a:w1.fi:hostapd:2.3
cpe:/a:w1.fi:hostapd:2.4
cpe:/a:w1.fi:hostapd:2.5
cpe:/a:w1.fi:hostapd:2.6
cpe:/a:w1.fi:wpa_supplicant:0.2.4
cpe:/a:w1.fi:wpa_supplicant:0.2.5
cpe:/a:w1.fi:wpa_supplicant:0.2.6
cpe:/a:w1.fi:wpa_supplicant:0.2.7
cpe:/a:w1.fi:wpa_supplicant:0.2.8
cpe:/a:w1.fi:wpa_supplicant:0.3.7
cpe:/a:w1.fi:wpa_supplicant:0.3.8
cpe:/a:w1.fi:wpa_supplicant:0.3.9
cpe:/a:w1.fi:wpa_supplicant:0.3.10
cpe:/a:w1.fi:wpa_supplicant:0.3.11
cpe:/a:w1.fi:wpa_supplicant:0.4.7
cpe:/a:w1.fi:wpa_supplicant:0.4.8
cpe:/a:w1.fi:wpa_supplicant:0.4.9
cpe:/a:w1.fi:wpa_supplicant:0.4.10
cpe:/a:w1.fi:wpa_supplicant:0.4.11
cpe:/a:w1.fi:wpa_supplicant:0.5.7
cpe:/a:w1.fi:wpa_supplicant:0.5.8
cpe:/a:w1.fi:wpa_supplicant:0.5.9
cpe:/a:w1.fi:wpa_supplicant:0.5.10
cpe:/a:w1.fi:wpa_supplicant:0.5.11
cpe:/a:w1.fi:wpa_supplicant:0.6.8
cpe:/a:w1.fi:wpa_supplicant:0.6.9
cpe:/a:w1.fi:wpa_supplicant:0.6.10
cpe:/a:w1.fi:wpa_supplicant:0.7.3
cpe:/a:w1.fi:wpa_supplicant:1.0
cpe:/a:w1.fi:wpa_supplicant:1.1
cpe:/a:w1.fi:wpa_supplicant:2.0
cpe:/a:w1.fi:wpa_supplicant:2.1
cpe:/a:w1.fi:wpa_supplicant:2.2
cpe:/a:w1.fi:wpa_supplicant:2.3
cpe:/a:w1.fi:wpa_supplicant:2.4
cpe:/a:w1.fi:wpa_supplicant:2.5
cpe:/a:w1.fi:wpa_supplicant:2.6
Configuration 3
OR
cpe:/o:suse:linux_enterprise_desktop:12:sp2
cpe:/o:suse:linux_enterprise_desktop:12:sp3
cpe:/o:suse:linux_enterprise_point_of_sale:11:sp3
cpe:/o:suse:linux_enterprise_server:11:sp3:~~~ltss~~
cpe:/o:suse:linux_enterprise_server:11:sp4
cpe:/o:suse:linux_enterprise_server:12::~~ltss~~~
cpe:/o:suse:openstack_cloud:6

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 7 change records found - show changes