National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-15698 Detail

Current Description

When parsing the AIA-Extension field of a client certificate, Apache Tomcat Native Connector 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 did not correctly handle fields longer than 127 bytes. The result of the parsing error was to skip the OCSP check. It was therefore possible for client certificates that should have been rejected (if the OCSP check had been made) to be accepted. Users not using OCSP checks are not affected by this vulnerability.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 5.9 MEDIUM
Vector:  CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securitytracker.com/id/1040390 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2018:0465 Third Party Advisory
https://access.redhat.com/errata/RHSA-2018:0466 Third Party Advisory
https://lists.apache.org/thread.html/6eb0a53e5827d97db1a05c736d01101fec21202a5b8fc77bb0eaaed8@%3Cannounce.tomcat.apache.org%3E Vendor Advisory
https://lists.apache.org/thread.html/ba661b0edd913b39ff129a32d855620dd861883ade05fd88a8ce517d@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/f8e0814e11c7f21f42224b6de111cb3f5e5ab5c15b78924c516d4ec2@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/re3b72cbb13e1dfe85c4a06959a3b6ca6d939b407ecca80db12b54220@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/rf8e8c091182b45daa50d3557cad9b10bb4198e3f08cf8f1c66a1b08d@%3Cdev.tomcat.apache.org%3E
https://lists.debian.org/debian-lts-announce/2018/02/msg00011.html Mailing List Third Party Advisory
https://www.debian.org/security/2018/dsa-4118 Third Party Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-295 Improper Certificate Validation NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:apache:tomcat_native:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
1.1.23
Up to (including)
1.1.34
 cpe:2.3:a:apache:tomcat_native:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
1.2.0
Up to (including)
1.2.14

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

10 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-15698
NVD Published Date:
01/31/2018
NVD Last Modified:
03/25/2019