National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-5532 Detail

Current Description

A vulnerability in the report renderer component of TIBCO JasperReports Server, TIBCO JasperReports Server Community Edition, TIBCO JasperReports Server for ActiveMatrix BPM, TIBCO JasperReports Library, TIBCO JasperReports Library for ActiveMatrix BPM, TIBCO Jaspersoft for AWS with Multi-Tenancy, TIBCO Jaspersoft Reporting and Analytics for AWS, TIBCO Jaspersoft Studio, and TIBCO Jaspersoft Studio for ActiveMatrix BPM may allow a subset of authorized users to perform persistent cross-site scripting (XSS) attacks. Affected releases are TIBCO JasperReports Server 6.2.3 and below; 6.3.0; 6.3.1; 6.3.2; 6.4.0, TIBCO JasperReports Server Community Edition 6.4.0 and below, TIBCO JasperReports Server for ActiveMatrix BPM 6.4.0 and below, TIBCO JasperReports Library 6.2.3 and below; 6.3.0; 6.3.1; 6.3.2; 6.4.0; 6.4.1, TIBCO JasperReports Library for ActiveMatrix BPM 6.4.1 and below, TIBCO Jaspersoft for AWS with Multi-Tenancy 6.4.0 and below, TIBCO Jaspersoft Reporting and Analytics for AWS 6.4.0 and below, TIBCO Jaspersoft Studio 6.2.3 and below; 6.3.0; 6.3.1; 6.3.2; 6.4.0, and TIBCO Jaspersoft Studio for ActiveMatrix BPM 6.4.0 and below.

Source:  MITRE      Last Modified:  11/15/2017      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2017-5532
Original release date:
11/15/2017
Last revised:
12/05/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
5.4 Medium
Vector:
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N (legend)
Impact Score:
2.7
Exploitability Score:
2.3
CVSS Version 3 Metrics:
Attack Vector (AV):
Network
Attack Complexity (AC):
Low
Privileges Required (PR):
Low
User Interaction (UI):
Required
Scope (S):
Changed
Confidentiality (C):
Low
Integrity (I):
Low
Availability (A):
None
CVSS Severity (version 2.0):
CVSS v2 Base Score:
3.5 LOW
Vector:
(AV:N/AC:M/Au:S/C:N/I:P/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
6.8
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Medium
Authentication:
Required to exploit
Impact Type:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://www.securityfocus.com/bid/101873 Issue Tracking; Third Party Advisory; VDB Entry External Source BID 101873
https://www.tibco.com/support/advisories/2017/11/tibco-security-advisory-november-15-2017-tibco-jasperreports-2017-5532 Issue Tracking; Vendor Advisory External Source CONFIRM https://www.tibco.com/support/advisories/2017/11/tibco-security-advisory-november-15-2017-tibco-jasperreports-2017-5532

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:tibco:jasperreports_server:*:*:*:*:*:*:*:*    versions up to (including) 6.2.3
cpe:2.3:a:tibco:jasperreports_server:6.3.0:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_server:6.3.1:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_server:6.3.2:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_server:6.4.0:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:tibco:jasperreports_server:*:*:community:*:*:*:*:*    versions up to (including) 6.4.0
Configuration 3
OR
cpe:2.3:a:tibco:jasperreports_server:*:*:*:*:*:activematrix_bpm:*:*    versions up to (including) 6.4.0
Configuration 4
OR
cpe:2.3:a:tibco:jasperreports_library:*:*:*:*:*:*:*:*    versions up to (including) 6.2.3
cpe:2.3:a:tibco:jasperreports_library:6.3.0:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_library:6.3.1:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_library:6.3.2:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_library:6.4.0:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jasperreports_library:6.4.1:*:*:*:*:*:*:*
Configuration 5
OR
cpe:2.3:a:tibco:jasperreports_library:*:*:*:*:*:activematrix_bpm:*:*    versions up to (including) 6.4.1
Configuration 6
OR
cpe:2.3:a:tibco:jaspersoft:*:*:*:*:*:aws_with_multi-tenancy:*:*    versions up to (including) 6.4.0
Configuration 7
OR
cpe:2.3:a:tibco:jaspersoft_reporting_and_analytics:*:*:*:*:*:aws:*:*    versions up to (including) 6.4.0
Configuration 8
OR
cpe:2.3:a:tibco:jaspersoft_studio:*:*:*:*:*:*:*:*    versions up to (including) 6.2.3
cpe:2.3:a:tibco:jaspersoft_studio:6.3.0:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jaspersoft_studio:6.3.1:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jaspersoft_studio:6.3.2:*:*:*:*:*:*:*
cpe:2.3:a:tibco:jaspersoft_studio:6.4.0:*:*:*:*:*:*:*
Configuration 9
OR
cpe:2.3:a:tibco:jaspersoft_studio:*:*:*:*:*:activematrix_bpm:*:*    versions up to (including) 6.4.0

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes