National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-5953 Detail

Current Description

vim before patch 8.0.0322 does not properly validate values for tree length when handling a spell file, which may result in an integer overflow at a memory allocation site and a resultant buffer overflow.

Source:  MITRE      Last Modified:  02/10/2017      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2017-5953
Original release date:
02/10/2017
Last revised:
11/03/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
9.8 Critical
Vector:
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (legend)
Impact Score:
5.9
Exploitability Score:
3.9
CVSS Version 3 Metrics:
Attack Vector (AV):
Network
Attack Complexity (AC):
Low
Privileges Required (PR):
None
User Interaction (UI):
None
Scope (S):
Unchanged
Confidentiality (C):
High
Integrity (I):
High
Availability (A):
High
CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://www.debian.org/security/2017/dsa-3786 External Source DEBIAN DSA-3786
http://www.securityfocus.com/bid/96217 External Source BID 96217
https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d Patch; Vendor Advisory External Source CONFIRM https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d
https://groups.google.com/forum/#%21topic/vim_dev/t-3RSdEnrHY Patch External Source CONFIRM https://groups.google.com/forum/#!topic/vim_dev/t-3RSdEnrHY
https://security.gentoo.org/glsa/201706-26 External Source GENTOO GLSA-201706-26

Technical Details

Vulnerability Type (View All)

  • Integer Overflow or Wraparound (CWE-190)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*    versions up to (including) 8.0.0055

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 6 change records found - show changes