National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-8924 Detail

Current Description

The edge_bulk_in_callback function in drivers/usb/serial/io_ti.c in the Linux kernel before 4.10.4 allows local users to obtain sensitive information (in the dmesg ringbuffer and syslog) from uninitialized kernel memory by using a crafted USB device (posing as an io_ti USB serial device) to trigger an integer underflow.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 4.6 MEDIUM
Vector:  CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=654b404f2a222f918af9b0cd18ad469d0c941a8e Issue Tracking Patch Third Party Advisory
http://www.debian.org/security/2017/dsa-3886 Third Party Advisory
http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.10.4 Release Notes Vendor Advisory
http://www.securityfocus.com/bid/98451 Third Party Advisory VDB Entry
https://github.com/torvalds/linux/commit/654b404f2a222f918af9b0cd18ad469d0c941a8e Issue Tracking Patch Third Party Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-191 Integer Underflow (Wrap or Wraparound) NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
4.10.3

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-8924
NVD Published Date:
05/12/2017
NVD Last Modified:
04/16/2019