National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-0240 Detail

Current Description

Multiple vulnerabilities in the Application Layer Protocol Inspection feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to trigger a reload of an affected device, resulting in a denial of service (DoS) condition. The vulnerabilities are due to logical errors during traffic inspection. An attacker could exploit these vulnerabilities by sending a high volume of malicious traffic across an affected device. An exploit could allow the attacker to cause a deadlock condition, resulting in a reload of an affected device. These vulnerabilities affect Cisco ASA Software and Cisco FTD Software configured for Application Layer Protocol Inspection running on the following Cisco products: 3000 Series Industrial Security Appliance (ISA), ASA 5500 Series Adaptive Security Appliances, ASA 5500-X Series Next-Generation Firewalls, ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, Adaptive Security Virtual Appliance (ASAv), Firepower 2100 Series Security Appliance, Firepower 4100 Series Security Appliance, Firepower 9300 ASA Security Module, FTD Virtual (FTDv). Cisco Bug IDs: CSCve61540, CSCvh23085, CSCvh95456.

Source:  MITRE
Description Last Modified:  04/19/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H (V3 legend)
Impact Score: 3.6
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): None
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 7.8 HIGH
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:C) (V2 legend)
Impact Subscore: 6.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/103934 Third Party Advisory VDB Entry
http://www.securitytracker.com/id/1040722 Third Party Advisory VDB Entry
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-asa_inspect Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.6.0.0 up to (excluding) 9.6.4.6
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.7.0.0 up to (excluding) 9.7.1.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.8.0.0 up to (excluding) 9.8.2.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.9.0.0 up to (excluding) 9.9.1.4
OR
cpe:2.3:h:cisco:asa-5505:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5520:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5540:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.6\(4\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.7\(1.17\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.8\(2.12\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:101.3\(1.23\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:101.3\(1.51\):*:*:*:*:*:*:*
OR
cpe:2.3:h:cisco:asa-5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5506h-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5512-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5515-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5545-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5555-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5585-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.8\(2.21\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:99.1\(20.190\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:99.2\(0.32\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:101.4\(1.24\):*:*:*:*:*:*:*
OR
cpe:2.3:h:cisco:asa-5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5506h-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5512-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5515-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5545-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5555-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5585-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.7\(1\):*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_appliance_software:9.9\(1.77\):*:*:*:*:*:*:*
OR
cpe:2.3:h:cisco:asa-5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5506h-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5512-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5515-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5545-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5555-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa-5585-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:*
Configuration 5
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.6.0.0 up to (excluding) 9.6.4.6
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.7.0.0 up to (excluding) 9.7.1.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.8.0.0 up to (excluding) 9.8.2.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.9.0.0 up to (excluding) 9.9.1.4
OR
cpe:2.3:h:cisco:isa-3000-2c2f:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:isa-3000-4c:-:*:*:*:*:*:*:*
Configuration 6
OR
cpe:2.3:a:cisco:adaptive_security_virtual_appliance:v5:*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_virtual_appliance:v10:*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_virtual_appliance:v30:*:*:*:*:*:*:*
cpe:2.3:a:cisco:adaptive_security_virtual_appliance:v50:*:*:*:*:*:*:*
Configuration 7
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.6.0.0 up to (excluding) 9.6.4.6
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.7.0.0 up to (excluding) 9.7.1.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.8.0.0 up to (excluding) 9.8.2.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.9.0.0 up to (excluding) 9.9.1.4
OR
cpe:2.3:h:cisco:firepower_2110:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_2120:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_2130:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_2140:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_4110:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_4120:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_4140:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_4150:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:firepower_9300:-:*:*:*:*:*:*:*
Configuration 8
AND
OR
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.6.0.0 up to (excluding) 9.6.4.6
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.7.0.0 up to (excluding) 9.7.1.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.8.0.0 up to (excluding) 9.8.2.24
cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:*    versions from (including) 9.9.0.0 up to (excluding) 9.9.1.4
OR
cpe:2.3:h:cisco:7604:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:7606-s:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:7609-s:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:7613-s:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:catalyst_6500-e:-:*:*:*:*:*:*:*
Configuration 9
OR
cpe:2.3:a:cisco:firepower_threat_defense_virtual:-:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-0240
NVD Published Date:
04/19/2018
NVD Last Modified:
05/24/2018