Vulnerability Change Records for CVE-2018-10612

Change History

CVE Modified by ICS-CERT 10/09/2019 7:32:55 PM

Action Type Old Value New Value
Added CWE

								
							
							
						
ICS-CERT CWE-284

Reanalysis 2/22/2019 10:14:39 AM

Action Type Old Value New Value
Changed CPE Configuration
OR
     *cpe:2.3:a:codesys:control_for_beaglebone_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_empc-a\/imx6_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_iot2000_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_linux_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_pfc100_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_pfc200_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_raspberry_pi_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_rte_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_runtime_toolkit:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_win_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:development_system_v3:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:hmi_sl:*:*:*:*:*:*:*:* versions up to (excluding) 3.5.14.0
OR
     *cpe:2.3:a:codesys:control_for_beaglebone_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_empc-a\/imx6_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_iot2000_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_linux_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_pfc100_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_pfc200_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_for_raspberry_pi_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_rte_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_runtime_toolkit:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:control_win_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:development_system_v3:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0
     *cpe:2.3:a:codesys:hmi_sl:*:*:*:*:*:*:*:* versions from (including) 3.0 up to (excluding) 3.5.14.0

CWE Remap 10/02/2019 8:3:26 PM

Action Type Old Value New Value
Changed CWE
CWE-284
CWE-310
CWE-732
CWE-311

CVE Modified by ICS-CERT 1/30/2019 10:29:00 AM

Action Type Old Value New Value
Added Reference

								
							
							
						
http://www.securityfocus.com/bid/106248 [No Types Assigned]