National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-1183 Detail

Current Description

In Dell EMC Unisphere for VMAX Virtual Appliance versions prior to 8.4.0.8, Dell EMC Solutions Enabler Virtual Appliance versions prior to 8.4.0.8, Dell EMC VASA Provider Virtual Appliance versions prior to 8.4.0.512, Dell EMC SMIS versions prior to 8.4.0.6, Dell EMC VMAX Embedded Management (eManagement) versions prior to and including 1.4.0.347, Dell EMC VNX2 Operating Environment (OE) for File versions prior to 8.1.9.231, Dell EMC VNX2 Operating Environment (OE) for Block versions prior to 05.33.009.5.231, Dell EMC VNX1 Operating Environment (OE) for File versions prior to 7.1.82.0, Dell EMC VNX1 Operating Environment (OE) for Block versions prior to 05.32.000.5.225, Dell EMC VNXe3200 Operating Environment (OE) all versions, Dell EMC VNXe1600 Operating Environment (OE) versions prior to 3.1.9.9570228, Dell EMC VNXe 3100/3150/3300 Operating Environment (OE) all versions, Dell EMC ViPR SRM versions 3.7, 3.7.1, 3.7.2 (only if using Dell EMC Host Interface for Windows), Dell EMC ViPR SRM versions 4.0, 4.0.1, 4.0.2, 4.0.3 (only if using Dell EMC Host Interface for Windows), Dell EMC XtremIO versions 4.x, Dell EMC VMAX eNAS version 8.x, Dell EMC Unity Operating Environment (OE) versions prior to 4.3.0.1522077968, ECOM is affected by a XXE injection vulnerability due to the configuration of the XML parser shipped with the product. XXE Injection attack may occur when XML input containing a reference to an external entity (defined by the attacker) is processed by an affected XML parser. XXE Injection may allow attackers to gain unauthorized access to files containing sensitive information or may be used to cause denial-of-service.

Source:  MITRE
Description Last Modified:  04/30/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 9.8 CRITICAL
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Insufficient_Info
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://seclists.org/fulldisclosure/2018/Apr/61 Mailing List Third Party Advisory
http://www.securityfocus.com/bid/104024 Third Party Advisory VDB Entry

Technical Details

Vulnerability Type (View All)

  • Improper Restriction of XML External Entity Reference ('XXE') (CWE-611)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:dell:emc_smis:*:*:*:*:*:*:*:*    versions up to (excluding) 8.4.0.6
cpe:2.3:a:dell:emc_solutions_enabler_virtual_appliance:*:*:*:*:*:*:*:*    versions up to (excluding) 8.4.0.8
cpe:2.3:a:dell:emc_unisphere:*:*:*:*:*:vmax_virtual_appliance:*:*    versions up to (excluding) 8.4.0.8
cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:*    versions up to (excluding) 4.3.0.1522077968
cpe:2.3:a:dell:emc_vasa_provider_virtual_appliance:*:*:*:*:*:*:*:*    versions up to (excluding) 8.4.0.512
cpe:2.3:a:dell:emc_vipr_srm:-:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vipr_srm:3.7:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:3.7.1:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:3.7.2:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:4.0:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:4.0.1:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:4.0.2:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vipr_srm:4.0.3:*:*:*:*:windows:*:*
cpe:2.3:a:dell:emc_vmax_embedded_management:*:*:*:*:*:*:*:*    versions up to (including) 1.4.0.347
cpe:2.3:a:dell:emc_vmax_enas:8.0:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vmax_enas:8.0.1:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vnx1_operating_environment:05.32.000.5.225:*:*:*:*:block:*:*
cpe:2.3:a:dell:emc_vnx1_operating_environment:7.1.82.0:*:*:*:*:file:*:*
cpe:2.3:a:dell:emc_vnx2_operating_environment:*:*:*:*:*:block:*:*    versions up to (excluding) 05.33.009.5.231
cpe:2.3:a:dell:emc_vnx2_operating_environment:*:*:*:*:*:file:*:*    versions up to (excluding) 8.1.9.231
cpe:2.3:a:dell:emc_vnxe1600_operating_environment:*:*:*:*:*:*:*:*    versions up to (excluding) 3.1.9.9570228
cpe:2.3:a:dell:emc_vnxe3200_operating_environment:-:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vnxe_3100_operating_environment:-:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vnxe_3150_operating_environment:-:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_vnxe_3300__operating_environment:-:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_xtremio:4.0:*:*:*:*:*:*:*
cpe:2.3:a:dell:emc_xtremio:4.0.2:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-1183
NVD Published Date:
04/30/2018
NVD Last Modified:
06/13/2018