CVE-2018-14665 Detail

Current Description

A flaw was found in xorg-x11-server before 1.20.3. An incorrect permission check for -modulepath and -logfile options when starting Xorg. X server allows unprivileged users with the ability to log in to the system via physical console to escalate their privileges and run arbitrary code under root privileges.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  6.6 MEDIUM
Vector:  CVSS:3.0/AV:P/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have published a CVSS score for this CVE based on publicly available information at the time of analysis. The CNA has not provided a score within the CVE List.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://packetstormsecurity.com/files/154942/Xorg-X11-Server-SUID-modulepath-Privilege-Escalation.html
http://packetstormsecurity.com/files/155276/Xorg-X11-Server-Local-Privilege-Escalation.html
http://www.securityfocus.com/bid/105741 Third Party Advisory  VDB Entry 
http://www.securitytracker.com/id/1041948 Third Party Advisory  VDB Entry 
https://access.redhat.com/errata/RHSA-2018:3410 Third Party Advisory 
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14665 Issue Tracking  Patch  Third Party Advisory 
https://gitlab.freedesktop.org/xorg/xserver/commit/50c0cf885a6e91c0ea71fb49fa8f1b7c86fe330e Patch  Third Party Advisory 
https://gitlab.freedesktop.org/xorg/xserver/commit/8a59e3b7dbb30532a7c3769c555e00d7c4301170 Patch  Third Party Advisory 
https://lists.x.org/archives/xorg-announce/2018-October/002927.html Mitigation  Patch  Vendor Advisory 
https://security.gentoo.org/glsa/201810-09 Third Party Advisory 
https://usn.ubuntu.com/3802-1/ Third Party Advisory 
https://www.debian.org/security/2018/dsa-4328 Third Party Advisory 
https://www.exploit-db.com/exploits/45697/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/45742/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/45832/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/45908/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/45922/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/45938/ Exploit  Third Party Advisory  VDB Entry 
https://www.exploit-db.com/exploits/46142/ Exploit  Third Party Advisory  VDB Entry 
https://www.securepatterns.com/2018/10/cve-2018-14665-xorg-x-server.html Exploit  Third Party Advisory 

Weakness Enumeration

CWE-ID CWE Name Source
CWE-863 Incorrect Authorization cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

13 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-14665
NVD Published Date:
10/25/2018
NVD Last Modified:
10/22/2019
Source:
MITRE