National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-5950 Detail

Current Description

Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows remote attackers to inject arbitrary web script or HTML via a user-options URL.

Source:  MITRE      Last Modified:  02/04/2018      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2018-5950
Original release date:
01/23/2018
Last revised:
02/10/2018
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
6.1 Medium
Vector:
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N (legend)
Impact Score:
2.7
Exploitability Score:
2.8
CVSS Version 3 Metrics:
Attack Vector (AV):
Network
Attack Complexity (AC):
Low
Privileges Required (PR):
None
User Interaction (UI):
Required
Scope (S):
Changed
Confidentiality (C):
Low
Integrity (I):
Low
Availability (A):
None
CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.3 MEDIUM
Vector:
(AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
8.6
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Medium
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
https://bugs.launchpad.net/mailman/+bug/1747209 Patch; Third Party Advisory External Source CONFIRM https://bugs.launchpad.net/mailman/+bug/1747209
https://lists.debian.org/debian-lts-announce/2018/02/msg00007.html External Source MLIST [debian-lts-announce] 20180209 [SECURITY] [DLA 1272-1] mailman security update
https://www.debian.org/security/2018/dsa-4108 External Source DEBIAN DSA-4108
https://www.mail-archive.com/mailman-users@python.org/msg70375.html Third Party Advisory External Source MLIST [mailman-users] 20180120 Mailman 2.1.26 Security release Feb 4, 2018

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:gnu:mailman:*:*:*:*:*:*:*:*    versions up to (excluding) 2.1.26

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 4 change records found - show changes