National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-0197 Detail

Current Description

A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on" are unaffected by this issue.

Source:  MITRE
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 4.2 MEDIUM
Vector: AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L (V3 legend)
Impact Score: 2.5
Exploitability Score: 1.6


Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): Low
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): Low
Availability (A): Low

CVSS v2.0 Severity and Metrics:

Base Score: 4.9 MEDIUM
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:P) (V2 legend)
Impact Subscore: 4.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00051.html Mailing List Patch Third Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00061.html Mailing List Patch Third Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00084.html Mailing List Patch Third Party Advisory
http://www.openwall.com/lists/oss-security/2019/04/02/2 Mailing List Third Party Advisory
http://www.securityfocus.com/bid/107665 Third Party Advisory VDB Entry
https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
https://lists.apache.org/thread.html/e0b8f6e858b1c8ec2ce8e291a2c543d438915037c7af661ab6d33808@%3Cdev.httpd.apache.org%3E Mailing List Release Notes Vendor Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WETXNQWNQLWHV6XNW6YTO5UGDTIWAQGT/ Third Party Advisory
https://security.netapp.com/advisory/ntap-20190617-0002/
https://support.f5.com/csp/article/K44591505 Third Party Advisory

Technical Details

Vulnerability Type (View All)

  • Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') (CWE-444)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
2.4.17
Up to (including)
2.4.38


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-0197
NVD Published Date:
06/11/2019
NVD Last Modified:
06/17/2019