National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-1605 Detail

Current Description

A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary code as root. The vulnerability is due to incorrect input validation in the NX-API feature. An attacker could exploit this vulnerability by sending a crafted HTTP or HTTPS request to an internal service on an affected device that has the NX-API feature enabled. A successful exploit could allow the attacker to cause a buffer overflow and execute arbitrary code as root. Note: The NX-API feature is disabled by default. MDS 9000 Series Multilayer Switches are affected in versions prior to 8.1(1). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I4(8) and 7.0(3)I7(1). Nexus 3500 Platform Switches are affected in versions prior to 6.0(2)A8(8). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected in versions prior to 7.3(2)N1(1). Nexus 7000 and 7700 Series Switches are affected in versions prior to 7.3(3)D1(1). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I4(8) and 7.0(3)I7(1). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).

Source:  MITRE
Description Last Modified:  03/08/2019
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 7.8 HIGH
Vector: AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 1.8


Attack Vector (AV): Local
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 7.2 HIGH
Vector: (AV:L/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/107313 Third Party Advisory VDB Entry
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-api-ex Patch Vendor Advisory

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.3 up to (excluding) 8.1\(1\)
OR
cpe:2.3:h:cisco:mds_9000:-:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 6.0\(2\)a8\(8\)
OR
cpe:2.3:h:cisco:nexus_3500:-:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)i5 up to (excluding) 7.0\(3\)i7\(1\)
OR
cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)f3 up to (excluding) 7.0\(3\)f3\(5\)
OR
cpe:2.3:h:cisco:nexus_3600:-:*:*:*:*:*:*:*
Configuration 5
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.2 up to (excluding) 7.3\(3\)d1\(1\)
OR
cpe:2.3:h:cisco:nexus_7000:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_7700:-:*:*:*:*:*:*:*
Configuration 6
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 7.0\(3\)i4\(8\)
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)i5 up to (excluding) 7.0\(3\)i7\(1\)
OR
cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:*
Configuration 7
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)f1 up to (excluding) 7.0\(3\)f3\(5\)
OR
cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:*
Configuration 8
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 7.0\(3\)i4\(8\)
OR
cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:*
Configuration 9
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 7.0\(3\)i4\(8\)
OR
cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:*
Configuration 10
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.3 up to (excluding) 7.3\(2\)n1\(1\)
OR
cpe:2.3:h:cisco:nexus_2000:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5500:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5600:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_6000:-:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-1605
NVD Published Date:
03/08/2019
NVD Last Modified:
03/12/2019