National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-6251 Detail

Current Description

WebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.

Source:  MITRE
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 8.1 HIGH
Vector: AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N (V3 legend)
Impact Score: 5.2
Exploitability Score: 2.8


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 5.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:N) (V2 legend)
Impact Subscore: 4.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00025.html Third Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00031.html Third Party Advisory
http://packetstormsecurity.com/files/152485/WebKitGTK-WPE-WebKit-URI-Spoofing-Code-Execution.html Third Party Advisory VDB Entry
http://www.openwall.com/lists/oss-security/2019/04/11/1 Mailing List Third Party Advisory
https://bugs.webkit.org/show_bug.cgi?id=194208 Issue Tracking Vendor Advisory
https://gitlab.gnome.org/GNOME/epiphany/issues/532 Exploit Patch Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HSCDI3635E37GL4BNJDRDT2KEUBDLGSO/ Mailing List Release Notes Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LACVFU4MYYRPJ3IEA4UCN5KUEAGCCJ72/ Mailing List Release Notes Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TNPI3R6QWDJBA5KNGA6QSMKYLY5RRHBZ/ Mailing List Release Notes Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UO3DIA54X7FOUWFZW5YXC2MZ6KNHG6SW/ Mailing List Release Notes Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YO5ZBUWOOXMVZPBYLZRDZF6ZQGBYJERQ/ Mailing List Release Notes Third Party Advisory
https://seclists.org/bugtraq/2019/Apr/21 Mailing List Third Party Advisory
https://trac.webkit.org/changeset/243434 Patch Vendor Advisory
https://usn.ubuntu.com/3948-1/ Third Party Advisory

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:gnome:epiphany:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
3.31.4

Configuration 2 ( hide )
 cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
2.24.1
 cpe:2.3:a:wpewebkit:wpe_webkit:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
2.24.1

Configuration 3 ( hide )
 cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 4 ( hide )
 cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 5 ( hide )
 cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

14 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-6251
NVD Published Date:
01/14/2019
NVD Last Modified:
05/15/2019