U.S. flag   An official website of the United States government
Dot gov

Official websites use .gov
A .gov website belongs to an official government organization in the United States.

Https

Secure .gov websites use HTTPS
A lock (Dot gov) or https:// means you've safely connected to the .gov website. Share sensitive information only on official, secure websites.

Search Results (Refine Search)

Search Parameters:
  • Results Type: Overview
  • Keyword (text search): cpe:2.3:a:vim:vim:7.0.014:*:*:*:*:*:*:*
  • CPE Name Search: true
There are 24 matching records.
Displaying matches 1 through 20.
Vuln ID Summary CVSS Severity
CVE-2021-4069

vim is vulnerable to Use After Free

Published: December 06, 2021; 7:15:07 AM -0500
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3984

vim is vulnerable to Heap-based Buffer Overflow

Published: December 01, 2021; 6:15:07 AM -0500
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-4019

vim is vulnerable to Heap-based Buffer Overflow

Published: December 01, 2021; 5:15:07 AM -0500
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3973

vim is vulnerable to Heap-based Buffer Overflow

Published: November 19, 2021; 7:15:09 AM -0500
V3.1: 7.8 HIGH
V2.0: 9.3 HIGH
CVE-2021-3974

vim is vulnerable to Use After Free

Published: November 19, 2021; 6:15:07 AM -0500
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3928

vim is vulnerable to Stack-based Buffer Overflow

Published: November 05, 2021; 11:15:08 AM -0400
V3.1: 7.8 HIGH
V2.0: 4.6 MEDIUM
CVE-2021-3927

vim is vulnerable to Heap-based Buffer Overflow

Published: November 05, 2021; 11:15:08 AM -0400
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3903

vim is vulnerable to Heap-based Buffer Overflow

Published: October 27, 2021; 5:15:08 PM -0400
V3.1: 7.8 HIGH
V2.0: 4.6 MEDIUM
CVE-2021-3872

vim is vulnerable to Heap-based Buffer Overflow

Published: October 19, 2021; 9:15:11 AM -0400
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3875

vim is vulnerable to Heap-based Buffer Overflow

Published: October 15, 2021; 10:15:07 AM -0400
V3.1: 5.5 MEDIUM
V2.0: 4.3 MEDIUM
CVE-2021-3796

vim is vulnerable to Use After Free

Published: September 15, 2021; 9:15:08 AM -0400
V3.1: 7.3 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3778

vim is vulnerable to Heap-based Buffer Overflow

Published: September 15, 2021; 4:15:06 AM -0400
V3.1: 7.8 HIGH
V2.0: 6.8 MEDIUM
CVE-2021-3770

vim is vulnerable to Heap-based Buffer Overflow

Published: September 06, 2021; 8:15:08 AM -0400
V3.1: 7.8 HIGH
V2.0: 4.6 MEDIUM
CVE-2019-20807

In Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby, or Lua).

Published: May 28, 2020; 10:15:11 AM -0400
V3.1: 5.3 MEDIUM
V2.0: 4.6 MEDIUM
CVE-2019-12735

getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_fails or nvim_input in Neovim.

Published: June 05, 2019; 10:29:11 AM -0400
V3.0: 8.6 HIGH
V2.0: 9.3 HIGH
CVE-2017-17087

fileio.c in Vim prior to 8.0.1263 sets the group ownership of a .swp file to the editor's primary group (which may be different from the group ownership of the original file), which allows local users to obtain sensitive information by leveraging an applicable group membership, as demonstrated by /etc/shadow owned by root:shadow mode 0640, but /etc/.shadow.swp owned by root:users mode 0640, a different vulnerability than CVE-2017-1000382.

Published: December 01, 2017; 3:29:00 AM -0500
V3.0: 5.5 MEDIUM
V2.0: 2.1 LOW
CVE-2017-1000382

VIM version 8.0.1187 (and other versions most likely) ignores umask when creating a swap file ("[ORIGINAL_FILENAME].swp") resulting in files that may be world readable or otherwise accessible in ways not intended by the user running the vi binary.

Published: October 31, 2017; 4:29:00 PM -0400
V3.0: 5.5 MEDIUM
V2.0: 2.1 LOW
CVE-2017-6350

An integer overflow at an unserialize_uep memory allocation site would occur for vim before patch 8.0.0378, if it does not properly validate values for tree length when reading a corrupted undo file, which may lead to resultant buffer overflows.

Published: February 27, 2017; 2:59:00 AM -0500
V3.0: 9.8 CRITICAL
V2.0: 7.5 HIGH
CVE-2017-6349

An integer overflow at a u_read_undo memory allocation site would occur for vim before patch 8.0.0377, if it does not properly validate values for tree length when reading a corrupted undo file, which may lead to resultant buffer overflows.

Published: February 27, 2017; 2:59:00 AM -0500
V3.0: 9.8 CRITICAL
V2.0: 7.5 HIGH
CVE-2017-5953

vim before patch 8.0.0322 does not properly validate values for tree length when handling a spell file, which may result in an integer overflow at a memory allocation site and a resultant buffer overflow.

Published: February 10, 2017; 2:59:00 AM -0500
V3.0: 9.8 CRITICAL
V2.0: 7.5 HIGH